summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-16 07:32:11 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-16 08:01:58 +0100
commitf54fa9a42db3343a0c3d80dd39d5ea8265636690 (patch)
treedf79931a5b8ae547413f0767f56d67c4580b96de /dev-python/plyvel/plyvel-1.5.1.ebuild
parentdev-python/hypothesis: Bump to 6.93.2 (diff)
downloadgentoo-f54fa9a42db3343a0c3d80dd39d5ea8265636690.tar.gz
gentoo-f54fa9a42db3343a0c3d80dd39d5ea8265636690.tar.bz2
gentoo-f54fa9a42db3343a0c3d80dd39d5ea8265636690.zip
dev-python/plyvel: Bump to 1.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/plyvel/plyvel-1.5.1.ebuild')
-rw-r--r--dev-python/plyvel/plyvel-1.5.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/plyvel/plyvel-1.5.1.ebuild b/dev-python/plyvel/plyvel-1.5.1.ebuild
new file mode 100644
index 000000000000..fb7c8b655e5a
--- /dev/null
+++ b/dev-python/plyvel/plyvel-1.5.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+# Disable PyPy3 for now because it is not stable enough:
+# https://github.com/wbolster/plyvel/issues/140
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python interface to LevelDB"
+HOMEPAGE="
+ https://github.com/wbolster/plyvel/
+ https://pypi.org/project/plyvel/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-libs/leveldb-1.21:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest
+
+src_configure() {
+ emake cython
+}
+
+python_test() {
+ rm -rf plyvel || die
+ epytest
+}