summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-30 19:30:53 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-30 19:30:53 +0100
commitb04faf919deec242445dfaab6b507f67c96df5b6 (patch)
tree6ae7a63e20a912dc75e3151d2729d02e1fe07b37 /dev-python/poetry
parentdev-python/podman: Remove old (diff)
downloadgentoo-b04faf919deec242445dfaab6b507f67c96df5b6.tar.gz
gentoo-b04faf919deec242445dfaab6b507f67c96df5b6.tar.bz2
gentoo-b04faf919deec242445dfaab6b507f67c96df5b6.zip
dev-python/poetry: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/poetry')
-rw-r--r--dev-python/poetry/Manifest1
-rw-r--r--dev-python/poetry/poetry-1.7.0.ebuild88
2 files changed, 0 insertions, 89 deletions
diff --git a/dev-python/poetry/Manifest b/dev-python/poetry/Manifest
index 27a7e6864b51..0b74924f0016 100644
--- a/dev-python/poetry/Manifest
+++ b/dev-python/poetry/Manifest
@@ -1,2 +1 @@
-DIST poetry-1.7.0.tar.gz 1482460 BLAKE2B 3bf91881bd38967a95cc5a881a74a91932488d4ad11b89c237c1c497107f3ce2ed1df7bccb01a415377082612f1905dc057c1ef680e1bf2aa5efa3b852b80417 SHA512 fc0d358d62100fcd14dec3bb13cc8162339ba4947c2118abb4ccefd788ea3e10750f92f4a51c8feb7f2d5cebf0ac670092e730518463c61bc49bd044a9a8e9c7
DIST poetry-1.7.1.tar.gz 1483927 BLAKE2B d32f84cbed6f895678fba723700504cafe2bb7b1de0be0f289c0606b3c775d02e4172d74aafe58f29f9e2b5b9cb0f614b902bb9efa55ab1077a6689a8b4d331f SHA512 bf3654e9de71da35d7adfc239797dbed9813a2a1bb585b0bd9ad398706ad1628430422d0ebe7d9c3dcc1f619ad1a1a2073e9d9d3296354bf2f14a1aed5a5444e
diff --git a/dev-python/poetry/poetry-1.7.0.ebuild b/dev-python/poetry/poetry-1.7.0.ebuild
deleted file mode 100644
index 35f6dc860f18..000000000000
--- a/dev-python/poetry/poetry-1.7.0.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A frontend for poetry - a python dependency management and packaging tool"
-HOMEPAGE="
- https://python-poetry.org/
- https://github.com/python-poetry/poetry
- https://pypi.org/project/poetry/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-# dev-python/build: 1.0 breaks backward compatibility
-# https://github.com/python-poetry/poetry/issues/8434
-RDEPEND="
- >=dev-python/poetry-core-1.8.1[${PYTHON_USEDEP}]
- >=dev-python/poetry-plugin-export-1.6.0[${PYTHON_USEDEP}]
- >=dev-python/build-1.0.3[${PYTHON_USEDEP}]
- >=dev-python/cachecontrol-0.13.0[${PYTHON_USEDEP}]
- >=dev-python/cleo-2.1.0[${PYTHON_USEDEP}]
- >=dev-python/crashtest-0.4.1[${PYTHON_USEDEP}]
- >=dev-python/dulwich-0.21.2[${PYTHON_USEDEP}]
- >=dev-python/fastjsonschema-2.18.0[${PYTHON_USEDEP}]
- >=dev-python/installer-0.7.0[${PYTHON_USEDEP}]
- >=dev-python/keyring-24.0.0[${PYTHON_USEDEP}]
- >=dev-python/packaging-20.5[${PYTHON_USEDEP}]
- >=dev-python/pexpect-4.7.0[${PYTHON_USEDEP}]
- >=dev-python/pkginfo-1.9.4[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.26[${PYTHON_USEDEP}]
- >=dev-python/requests-toolbelt-0.10.1[${PYTHON_USEDEP}]
- >=dev-python/shellingham-1.5.0[${PYTHON_USEDEP}]
- >=dev-python/tomlkit-0.11.6[${PYTHON_USEDEP}]
- >=dev-python/trove-classifiers-2022.5.19[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-20.23.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
- ' 3.10)
-"
-
-BDEPEND="
- test? (
- >=dev-python/deepdiff-6.3.1[${PYTHON_USEDEP}]
- >=dev-python/httpretty-1.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-mock-3.9[${PYTHON_USEDEP}]
- >=dev-python/pytest-xdist-3.1[${PYTHON_USEDEP}]
- )
-"
-
-src_prepare() {
- # unpin
- sed -e 's:\^:>=:' \
- -e '/poetry-core/s:":">=:' \
- -e 's:,<[0-9.]*::' \
- -i pyproject.toml || die
-
- distutils-r1_src_prepare
-}
-
-EPYTEST_DESELECT=(
- # Tests require network (they run `pip install ...`)
- tests/installation/test_chef.py::test_isolated_env_install_success
- tests/installation/test_executor.py::test_executor_should_write_pep610_url_references_for_directories
- tests/installation/test_executor.py::test_executor_should_write_pep610_url_references_for_git
- tests/installation/test_executor.py::test_executor_should_write_pep610_url_references_for_git_with_subdirectories
- tests/installation/test_executor.py::test_executor_should_write_pep610_url_references_for_non_wheel_files
- tests/installation/test_installer.py::test_installer_with_pypi_repository
- tests/installation/test_pip_installer.py::test_uninstall_git_package_nspkg_pth_cleanup
- tests/masonry/builders/test_editable_builder.py::test_builder_setup_generation_runs_with_pip_editable
-
- # Works with network, but otherwise: Backend 'poetry.core.masonry.api' is not available.
- tests/installation/test_chef.py::test_prepare_sdist
- tests/installation/test_chef.py::test_prepare_directory
- tests/installation/test_chef.py::test_prepare_directory_with_extensions
- tests/installation/test_chef.py::test_prepare_directory_editable
-)
-
-distutils_enable_tests pytest