summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2024-04-05 13:19:23 +0700
committerAndrey Grozin <grozin@gentoo.org>2024-04-05 13:19:23 +0700
commit0ac626003486716297a39e83e955fa9bc9fdbfe0 (patch)
treef755b5c2c282907d8492fead16e01b15dc1bab75 /dev-python/pudb
parentsci-libs/huggingface_hub: add 0.20.3, drop 0.19.4 (diff)
downloadgentoo-0ac626003486716297a39e83e955fa9bc9fdbfe0.tar.gz
gentoo-0ac626003486716297a39e83e955fa9bc9fdbfe0.tar.bz2
gentoo-0ac626003486716297a39e83e955fa9bc9fdbfe0.zip
dev-python/pudb: added optfeature
Closes: https://bugs.gentoo.org/928595 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-python/pudb')
-rw-r--r--dev-python/pudb/pudb-2024.1.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-python/pudb/pudb-2024.1.ebuild b/dev-python/pudb/pudb-2024.1.ebuild
index 60d393757f68..a62662f987a3 100644
--- a/dev-python/pudb/pudb-2024.1.ebuild
+++ b/dev-python/pudb/pudb-2024.1.ebuild
@@ -6,10 +6,12 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} )
-inherit distutils-r1 pypi
+inherit distutils-r1 pypi optfeature
DESCRIPTION="A full-screen, console-based Python debugger"
-HOMEPAGE="https://pypi.org/project/pudb/"
+HOMEPAGE="https://documen.tician.de/pudb/
+ https://github.com/inducer/pudb
+ https://pypi.org/project/pudb/"
LICENSE="MIT"
SLOT="0"
@@ -27,3 +29,8 @@ BDEPEND="
"
distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature_header "Install the following packages for additional functionality:"
+ optfeature "Auto-complete support" dev-python/jedi
+}