summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-08-10 21:23:51 -0500
committerAlex Brandt <alunduil@gentoo.org>2015-08-10 21:23:51 -0500
commit7231eb4934d28087400b7db0628f0fe0a7cb505a (patch)
treeb6f06b94d430ec541eb8d00b653ebafce5be3915 /dev-python/pydispatcher/pydispatcher-2.0.5.ebuild
parentnet-fs/tahoe-lafs: version bump to 1.10.2 (diff)
downloadgentoo-7231eb4934d28087400b7db0628f0fe0a7cb505a.tar.gz
gentoo-7231eb4934d28087400b7db0628f0fe0a7cb505a.tar.bz2
gentoo-7231eb4934d28087400b7db0628f0fe0a7cb505a.zip
dev-python/pydispatcher: add python3 targets
Package-Manager: portage-2.2.20
Diffstat (limited to 'dev-python/pydispatcher/pydispatcher-2.0.5.ebuild')
-rw-r--r--dev-python/pydispatcher/pydispatcher-2.0.5.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/dev-python/pydispatcher/pydispatcher-2.0.5.ebuild b/dev-python/pydispatcher/pydispatcher-2.0.5.ebuild
index 9e1598a0dac2..f1121b9b9e90 100644
--- a/dev-python/pydispatcher/pydispatcher-2.0.5.ebuild
+++ b/dev-python/pydispatcher/pydispatcher-2.0.5.ebuild
@@ -3,16 +3,15 @@
# $Id$
EAPI=5
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
-inherit distutils-r1
+inherit distutils-r1 vcs-snapshot
MY_PN="PyDispatcher"
-MY_P="${MY_PN}-${PV}"
DESCRIPTION="Multi-producer-multi-consumer signal dispatching mechanism"
HOMEPAGE="http://pydispatcher.sourceforge.net/ http://pypi.python.org/pypi/PyDispatcher"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
@@ -22,8 +21,6 @@ IUSE="doc examples"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND=""
-S="${WORKDIR}/${MY_P}"
-
python_compile_all() {
if use doc; then
pushd docs/pydoc/ > /dev/null