summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-29 20:57:06 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-29 21:37:42 +0200
commitb6d24667ef56cd0878f23a37e9e5905635677b0d (patch)
tree519220568cd4a6f797a82c31dc355872ca8ed962 /dev-python/pyicu/pyicu-2.8.ebuild
parentsys-cluster/kube-scheduler: 1.22.3 bump (diff)
downloadgentoo-b6d24667ef56cd0878f23a37e9e5905635677b0d.tar.gz
gentoo-b6d24667ef56cd0878f23a37e9e5905635677b0d.tar.bz2
gentoo-b6d24667ef56cd0878f23a37e9e5905635677b0d.zip
dev-python/pyicu: Bump to 2.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyicu/pyicu-2.8.ebuild')
-rw-r--r--dev-python/pyicu/pyicu-2.8.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pyicu/pyicu-2.8.ebuild b/dev-python/pyicu/pyicu-2.8.ebuild
new file mode 100644
index 000000000000..4c203aac2bbc
--- /dev/null
+++ b/dev-python/pyicu/pyicu-2.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=${P/-/-v}
+DESCRIPTION="Python bindings for dev-libs/icu"
+HOMEPAGE="
+ https://gitlab.pyicu.org/main/pyicu/
+ https://pypi.org/project/PyICU/"
+SRC_URI="
+ https://gitlab.pyicu.org/main/pyicu/-/archive/v${PV}/${MY_P}.tar.bz2"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/icu:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? ( dev-python/six[${PYTHON_USEDEP}] )"
+
+DOCS=( CHANGES CREDITS README.md )
+
+distutils_enable_tests pytest