summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pypeg2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pypeg2')
-rw-r--r--dev-python/pypeg2/Manifest1
-rw-r--r--dev-python/pypeg2/files/pypeg2-2.15.1-test.patch12
-rw-r--r--dev-python/pypeg2/metadata.xml9
-rw-r--r--dev-python/pypeg2/pypeg2-2.15.1.ebuild30
4 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pypeg2/Manifest b/dev-python/pypeg2/Manifest
new file mode 100644
index 000000000000..53719f8891a3
--- /dev/null
+++ b/dev-python/pypeg2/Manifest
@@ -0,0 +1 @@
+DIST pyPEG2-2.15.1.tar.gz 24103 SHA256 f4814a5f9c84bbb0794bef8d2a5871f4aed25366791c55e2162681873ad8bd21 SHA512 53fc9f40d426384c6107e62fa76dd231d7abe7eba3144f29a6eb9374bd7f6bc2f209fc8a687a6df762a0ba98abdb1071783780acd85cd637f86692baafe52ad1 WHIRLPOOL 61ad75f1570afd4c2a282e3196c909b69af3b1d7f36a3b42b613be3a613785c75a4938948c5dfac50098ccea464a0a03564fe6c4ce8b4a8d7b6ec3cd36f58bb6
diff --git a/dev-python/pypeg2/files/pypeg2-2.15.1-test.patch b/dev-python/pypeg2/files/pypeg2-2.15.1-test.patch
new file mode 100644
index 000000000000..6ca8839d7776
--- /dev/null
+++ b/dev-python/pypeg2/files/pypeg2-2.15.1-test.patch
@@ -0,0 +1,12 @@
+Drop seemingly wrong test line that throws an AttributeError.
+
+--- pyPEG2-2.15.1/pypeg2/test/test_pyPEG2.py
++++ pyPEG2-2.15.1/pypeg2/test/test_pyPEG2.py
+@@ -255,7 +255,6 @@
+ def runTest(self):
+ r = pypeg2.parse("!all", type(self).C1)
+ self.assertEqual(str(r), "all")
+- self.assertEqual(r._ignore1, None)
+
+ class ParseOmitTestCase(ParserTestCase):
+ def runTest(self):
diff --git a/dev-python/pypeg2/metadata.xml b/dev-python/pypeg2/metadata.xml
new file mode 100644
index 000000000000..09eafda74579
--- /dev/null
+++ b/dev-python/pypeg2/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">pyPEG2</remote-id>
+ <remote-id type="bitbucket">fdik/pypeg</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pypeg2/pypeg2-2.15.1.ebuild b/dev-python/pypeg2/pypeg2-2.15.1.ebuild
new file mode 100644
index 000000000000..0dc8266d91db
--- /dev/null
+++ b/dev-python/pypeg2/pypeg2-2.15.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN=pyPEG2
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="An intrinsic PEG Parser-Interpreter for Python"
+HOMEPAGE="http://fdik.org/pyPEG/ https://bitbucket.org/fdik/pypeg/ https://pypi.python.org/pypi/pyPEG2"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${P}-test.patch )
+
+python_test() {
+ "${PYTHON}" -m unittest discover || die "Tests failed with ${EPYTHON}"
+}