summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-29 13:43:16 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-29 18:29:52 +0200
commit37ab9188667c833dc1296136d30226cb8f00835f (patch)
tree63d876424ef680fa5da4bf610d64a662683d5c5f /dev-python/pypy3
parentdev-python/pypy3_10: Bump to 7.3.17 (diff)
downloadgentoo-37ab9188667c833dc1296136d30226cb8f00835f.tar.gz
gentoo-37ab9188667c833dc1296136d30226cb8f00835f.tar.bz2
gentoo-37ab9188667c833dc1296136d30226cb8f00835f.zip
dev-python/pypy3: Bump to 7.3.17
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pypy3')
-rw-r--r--dev-python/pypy3/pypy3-7.3.17.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pypy3/pypy3-7.3.17.ebuild b/dev-python/pypy3/pypy3-7.3.17.ebuild
new file mode 100644
index 000000000000..4aa3928c48c5
--- /dev/null
+++ b/dev-python/pypy3/pypy3-7.3.17.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYVER=3.10
+DESCRIPTION="A fast, compliant alternative implementation of the Python (${PYVER}) language"
+HOMEPAGE="
+ https://pypy.org/
+ https://foss.heptapod.net/pypy/pypy/
+"
+S=${WORKDIR}
+
+LICENSE="MIT"
+SLOT="0/pypy310-pp73-384"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+gdbm ncurses sqlite tk"
+
+RDEPEND="
+ =dev-python/pypy3_10-${PV}*:${SLOT}[gdbm?,ncurses?,sqlite?,tk?]
+"
+
+src_install() {
+ dodir /usr/bin
+ dosym pypy${PYVER} /usr/bin/pypy3
+}