summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2022-06-29 14:31:21 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-07-25 09:04:39 +0300
commitbda0035a3bcaaf2016ba0b8018abd13dca206d81 (patch)
treeee11620bf84ccc1f9d8a848ec777a9f070bfbfe1 /dev-python/pyroute2
parentmedia-libs/babl: add upstream bug link to patch (diff)
downloadgentoo-bda0035a3bcaaf2016ba0b8018abd13dca206d81.tar.gz
gentoo-bda0035a3bcaaf2016ba0b8018abd13dca206d81.tar.bz2
gentoo-bda0035a3bcaaf2016ba0b8018abd13dca206d81.zip
dev-python/pyroute2: bump to 0.7.1
Closes: https://bugs.gentoo.org/815394 Signed-off-by: Henning Schild <henning@hennsch.de> Closes: https://github.com/gentoo/gentoo/pull/26144 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/pyroute2')
-rw-r--r--dev-python/pyroute2/Manifest1
-rw-r--r--dev-python/pyroute2/files/0001-setup-specify-build-backend-in-pyproject.toml.patch21
-rw-r--r--dev-python/pyroute2/pyroute2-0.7.1.ebuild37
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pyroute2/Manifest b/dev-python/pyroute2/Manifest
index 7fd04e2423dd..ea3dd08ef3e7 100644
--- a/dev-python/pyroute2/Manifest
+++ b/dev-python/pyroute2/Manifest
@@ -1 +1,2 @@
DIST pyroute2-0.5.19.gh.tar.gz 457432 BLAKE2B ffb2717c60badb1453eeb15f5b83f1494e851ee011fcdebd3a5d249ecc4bea7064069a1af2fe2d34aefe9812c8b6808b8a14cbe518383c165b0b008d10505c5c SHA512 19b0acbff17415acad20a214e0622ca9a3fc51b92e603ab15663ea7e8da290fc0b2033aeca1c20200307e34173802f89998151f77d5bcfc5f87eb8b42ba591ce
+DIST pyroute2-0.7.1.gh.tar.gz 460164 BLAKE2B 0555da23cc93cdd9b82c9516c5cf2046ca8bccbe122672045a101a3b1feb1582ef3ed987cac9d5a92d86fa1101346aed285aa2524b8474efe089ce66f839df36 SHA512 575e360fb2bcd659a7dc13080eb2deb39015427c6d248dc966f0d48a2cbfe25ec85545001a26a077396be8544ec90e4201fd459f464815d1e4b472e92c640d6e
diff --git a/dev-python/pyroute2/files/0001-setup-specify-build-backend-in-pyproject.toml.patch b/dev-python/pyroute2/files/0001-setup-specify-build-backend-in-pyproject.toml.patch
new file mode 100644
index 000000000000..9c5756dbf7a0
--- /dev/null
+++ b/dev-python/pyroute2/files/0001-setup-specify-build-backend-in-pyproject.toml.patch
@@ -0,0 +1,21 @@
+From c4e0bdcf0fc694c9f0f3b01908a5fd1bc6909e39 Mon Sep 17 00:00:00 2001
+From: Henning Schild <henning@hennsch.de>
+Date: Mon, 18 Jul 2022 08:45:21 +0200
+Subject: [PATCH] setup: specify "build-backend" in pyproject.toml
+
+Fixes: 9714df3404b5 ("setup: remove setup.py")
+---
+ pyproject.toml | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/pyproject.toml b/pyproject.toml
+index d1e6ae6e5647..9787c3bdf008 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -1,2 +1,3 @@
+ [build-system]
+ requires = ["setuptools", "wheel"]
++build-backend = "setuptools.build_meta"
+--
+2.35.1
+
diff --git a/dev-python/pyroute2/pyroute2-0.7.1.ebuild b/dev-python/pyroute2/pyroute2-0.7.1.ebuild
new file mode 100644
index 000000000000..8ed2d5d04f85
--- /dev/null
+++ b/dev-python/pyroute2/pyroute2-0.7.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8,9,10} pypy3 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A pure Python netlink and Linux network configuration library"
+HOMEPAGE="https://github.com/svinota/pyroute2"
+
+SRC_URI="
+ https://github.com/svinota/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/0001-setup-specify-build-backend-in-pyproject.toml.patch"
+)
+
+# tests need root access
+RESTRICT="test"