summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-09-29 22:07:00 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-29 22:07:00 +0300
commitce0ca120fdd5ed6ac1e597aeec91c29e75637390 (patch)
tree32239e878c496f6f130802f557fe2497b263bcde /dev-python/pyspnego
parentdev-python/fonttools: add 4.43.0 (diff)
downloadgentoo-ce0ca120fdd5ed6ac1e597aeec91c29e75637390.tar.gz
gentoo-ce0ca120fdd5ed6ac1e597aeec91c29e75637390.tar.bz2
gentoo-ce0ca120fdd5ed6ac1e597aeec91c29e75637390.zip
dev-python/pyspnego: add 0.10.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pyspnego')
-rw-r--r--dev-python/pyspnego/Manifest1
-rw-r--r--dev-python/pyspnego/pyspnego-0.10.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyspnego/Manifest b/dev-python/pyspnego/Manifest
index c5db1b833042..396548043ecc 100644
--- a/dev-python/pyspnego/Manifest
+++ b/dev-python/pyspnego/Manifest
@@ -1,3 +1,4 @@
DIST pyspnego-0.10.0.tar.gz 221948 BLAKE2B b98ec74c4e0896a27ef718a426bd030113b57397b5fc8337d826a71dc3ff5068b95c8ee439615c7ab067ed4caf8f5801f3430bd3dce67286a14952e7797c2941 SHA512 4ab2c1e51c1e79a9b241600aa40d4a0ed70958d4cd9c2dba0f11e02e980810c0bc67cdb89b10eea3c42c84dcb8f98e284c108cfee75ae87a3107870cab854209
+DIST pyspnego-0.10.1.tar.gz 222011 BLAKE2B d7089023cf968029d6ec29216bda154824f19a504ab76ad9f3032fcb6c821ca67435bff7c54a86a881fd802787433e61530a458b797d8c91d19ae25b8766b016 SHA512 881291d3d5f81d0970f1b2cea201c055baf3973aae84cf15995e6f2c5a0ac8a23686e49b163f7d85b8fd0226f98de59bafc939c6983d1a81e954a3f22b34714e
DIST pyspnego-0.9.1.tar.gz 233824 BLAKE2B c36d2ee697ed9dcb7a3c7d3a3ec2bc58b88ac6ba5a020c852b4ba7d0a01d3dd4a3801d91a9456f3f4710684df16a3a4c7d449cfa58e141ae5085bef0f0fe6f21 SHA512 6c516cae43bff523ec19b6ef52e7691a688bada027a183b98e0121bdd4f44f887a5fa87f3ab173dff1e18d84a7886a2a04de80dbd6873cc1dafb1d7369a9d932
DIST pyspnego-0.9.2.tar.gz 233819 BLAKE2B e4fc4b8cd760210c2e4dd188a651725fa6579fe429ca227e8a5cc1f46111e3e8e6cb07bc4256f60560d86bcd0a2b2e621efbd0dc193d3f67f66a1fdb79ef8f9e SHA512 6775efa12b1f93addf9257145d020e5fcb5139edf8ffcbdca03cd55de7ee992b47af5278206de85e50a824abbf0a037a50dc7e47ca5b6f79b2f4e854d926a8f3
diff --git a/dev-python/pyspnego/pyspnego-0.10.1.ebuild b/dev-python/pyspnego/pyspnego-0.10.1.ebuild
new file mode 100644
index 000000000000..408e9482cad6
--- /dev/null
+++ b/dev-python/pyspnego/pyspnego-0.10.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Library to handle SPNEGO and CredSSP authentication"
+HOMEPAGE="
+ https://github.com/jborean93/pyspnego/
+ https://pypi.org/project/pyspnego/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/gssapi[${PYTHON_USEDEP}]
+ >=dev-python/krb5-0.3.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "Kerberos authentication" "dev-python/gssapi >=dev-python/krb5-0.3.0"
+ optfeature "YAML output support" "dev-python/ruamel-yaml"
+}