summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-01 02:19:17 +0100
committerSam James <sam@gentoo.org>2022-06-01 02:25:17 +0100
commit91becb938f6773480531e1b6cc7716288a6fff8f (patch)
tree45c288f4c91415babc75ff32451b7dd2b7c4b328 /dev-python/pysrt
parentdev-python/enzyme: drop 9999 (diff)
downloadgentoo-91becb938f6773480531e1b6cc7716288a6fff8f.tar.gz
gentoo-91becb938f6773480531e1b6cc7716288a6fff8f.tar.bz2
gentoo-91becb938f6773480531e1b6cc7716288a6fff8f.zip
dev-python/pysrt: EAPI 8, Python 3.11, PEP517
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pysrt')
-rw-r--r--dev-python/pysrt/pysrt-1.1.2-r1.ebuild25
-rw-r--r--dev-python/pysrt/pysrt-9999.ebuild13
2 files changed, 32 insertions, 6 deletions
diff --git a/dev-python/pysrt/pysrt-1.1.2-r1.ebuild b/dev-python/pysrt/pysrt-1.1.2-r1.ebuild
new file mode 100644
index 000000000000..d7d904f7615e
--- /dev/null
+++ b/dev-python/pysrt/pysrt-1.1.2-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Python library used to edit or create SubRip files"
+HOMEPAGE="https://github.com/byroot/pysrt https://pypi.org/project/pysrt/"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/byroot/pysrt.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
diff --git a/dev-python/pysrt/pysrt-9999.ebuild b/dev-python/pysrt/pysrt-9999.ebuild
index 89d133c23ec7..d7d904f7615e 100644
--- a/dev-python/pysrt/pysrt-9999.ebuild
+++ b/dev-python/pysrt/pysrt-9999.ebuild
@@ -1,19 +1,20 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( pypy3 python3_{7..10} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
inherit distutils-r1
DESCRIPTION="Python library used to edit or create SubRip files"
HOMEPAGE="https://github.com/byroot/pysrt https://pypi.org/project/pysrt/"
-if [[ ${PV} == "9999" ]]; then
+if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/byroot/pysrt.git"
else
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi
LICENSE="GPL-3+"
@@ -21,4 +22,4 @@ SLOT="0"
RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]"
-distutils_enable_tests nose
+distutils_enable_tests pytest