summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-18 14:51:32 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-18 16:03:27 +0200
commit2d5dd8700740729b439193f0e3e460b0cf553d66 (patch)
tree23e33c5c8c143c343b0b28f621801fcdd8ec0de4 /dev-python/pytest-env
parentdev-python/sphinx-autodoc-typehints: Bump to 2.4.3 (diff)
downloadgentoo-2d5dd8700740729b439193f0e3e460b0cf553d66.tar.gz
gentoo-2d5dd8700740729b439193f0e3e460b0cf553d66.tar.bz2
gentoo-2d5dd8700740729b439193f0e3e460b0cf553d66.zip
dev-python/pytest-env: Bump to 1.1.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-env')
-rw-r--r--dev-python/pytest-env/Manifest1
-rw-r--r--dev-python/pytest-env/pytest-env-1.1.5.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pytest-env/Manifest b/dev-python/pytest-env/Manifest
index a69c5d927b62..0c18df4cac45 100644
--- a/dev-python/pytest-env/Manifest
+++ b/dev-python/pytest-env/Manifest
@@ -1,2 +1,3 @@
DIST pytest_env-1.1.3.tar.gz 8627 BLAKE2B 04aee8a84b2224ce1f0bb018d0d5a8f8542d32aa3e3da0ed03afdace2562b1643f712152128f7d673e118a4db9ab10c7440f44728ba774519ceb989b4c9be7f2 SHA512 c38371a272987757774bed6b566b55ba2304ca37e69f3f5671fb03735bbdfe5e51c3b03cd885d6bdbd73496daa95a57d79e03bf5d9171f0e9c5c0ae38492b304
DIST pytest_env-1.1.4.tar.gz 8898 BLAKE2B 8e6d9af2de86af47b5429e64112f7bbd4824fa54a7ffd2a7deb63da2032f6104587594a9efcddfc56a4dd7ef969b1a6cb4150906c029437c960ad02b0e215513 SHA512 9cde819b4f68f1a19de58c86651427c608b160bdfb6b6e12c6f4b90f195a759573e442d92df08f70b807282d4b47a7c078fa0b4674433d8778a9b8fb5552209e
+DIST pytest_env-1.1.5.tar.gz 8911 BLAKE2B 77195479f0a7bfe7b82b164f30c73e37f05002b33b19b605a056f476d02dedf8ed7eb0e116fe88c00dff2732f31d271539389eb790bcd4602c62f93e732530e9 SHA512 8f7df6d823067f55b3e761acee76744dc64e2e0f0c1e19ef5ab4db3215e92843279742782e654e652af025126f6c31ba86a54e3ef9e2223ca6057fbdc136ddd1
diff --git a/dev-python/pytest-env/pytest-env-1.1.5.ebuild b/dev-python/pytest-env/pytest-env-1.1.5.ebuild
new file mode 100644
index 000000000000..bfda9aab1b32
--- /dev/null
+++ b/dev-python/pytest-env/pytest-env-1.1.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin that allows you to add environment variables"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-env/
+ https://pypi.org/project/pytest-env/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-7.4.2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ >=dev-python/hatch-vcs-0.3[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.10.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # upstream lower bounds are meaningless
+ sed -i -e 's:>=[0-9.]*::' pyproject.toml || die
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}