summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-10 22:34:39 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-10 22:38:21 +0200
commit443d620a15c388a6a418c733a9cfb31ea357f6b0 (patch)
tree03b6143ac294de9066f734a1c5741b1409d5b460 /dev-python/pytest-mock
parentdev-python/pytest-asyncio: Enable py3.11 (diff)
downloadgentoo-443d620a15c388a6a418c733a9cfb31ea357f6b0.tar.gz
gentoo-443d620a15c388a6a418c733a9cfb31ea357f6b0.tar.bz2
gentoo-443d620a15c388a6a418c733a9cfb31ea357f6b0.zip
dev-python/pytest-mock: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-mock')
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.7.0.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/dev-python/pytest-mock/pytest-mock-3.7.0.ebuild b/dev-python/pytest-mock/pytest-mock-3.7.0.ebuild
index a54aa61c82c0..6266e8ce070c 100644
--- a/dev-python/pytest-mock/pytest-mock-3.7.0.ebuild
+++ b/dev-python/pytest-mock/pytest-mock-3.7.0.ebuild
@@ -4,11 +4,15 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
inherit distutils-r1
DESCRIPTION="Thin-wrapper around the mock package for easier use with pytest"
-HOMEPAGE="https://github.com/pytest-dev/pytest-mock/"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-mock/
+ https://pypi.org/project/pytest-mock/
+"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
@@ -16,21 +20,24 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
RDEPEND="
- >=dev-python/pytest-6[${PYTHON_USEDEP}]"
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+"
BDEPEND="
dev-python/setuptools_scm[${PYTHON_USEDEP}]
test? (
dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- )"
+ )
+"
distutils_enable_tests pytest
python_test() {
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
local -x PYTEST_PLUGINS=pytest_mock,pytest_asyncio.plugin
+ local EPYTEST_DESELECT=()
if has_version dev-python/mock; then
- local EPYTEST_DESELECT=(
+ EPYTEST_DESELECT+=(
tests/test_pytest_mock.py::test_standalone_mock
)
fi