summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-29 17:38:24 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-29 20:09:40 +0200
commitd479a718c46e159fb2372b2e5ded09d94142e07a (patch)
treef2263dfc79d972461ce740dec8e0877cd0fa08d2 /dev-python/pytest-subtests
parentmedia-libs/hamlib: remove unused patch(es) (diff)
downloadgentoo-d479a718c46e159fb2372b2e5ded09d94142e07a.tar.gz
gentoo-d479a718c46e159fb2372b2e5ded09d94142e07a.tar.bz2
gentoo-d479a718c46e159fb2372b2e5ded09d94142e07a.zip
dev-python/pytest-subtests: Bump to 0.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-subtests')
-rw-r--r--dev-python/pytest-subtests/Manifest1
-rw-r--r--dev-python/pytest-subtests/pytest-subtests-0.5.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pytest-subtests/Manifest b/dev-python/pytest-subtests/Manifest
index b75f934bdec9..474eb1eb9d56 100644
--- a/dev-python/pytest-subtests/Manifest
+++ b/dev-python/pytest-subtests/Manifest
@@ -1 +1,2 @@
DIST pytest-subtests-0.4.0.tar.gz 9673 BLAKE2B 780fbbdc6d4ac88c87002ee14323a0dd1036ab3dadc14b79ef11982459c60635add77e97575521ba0bda61317582e090353b427d945eca7198e294eb3d895240 SHA512 00302f47d1699e053314b6b4eee7c84a04fe0f51f287e338374bbd518c7d245d839ea0f1ccf50d4f35c86138cf6ea36da26e67bf41295205fb38323f2ad89f89
+DIST pytest-subtests-0.5.0.tar.gz 9793 BLAKE2B c671eb14189c0fd34180a636592b20c9e2b4225c5faf3b702103164e60bdbac4c9644e464f1e0c783da3da1263f7b841ea7a4149bcbf1de23325a8ef3ce5c030 SHA512 e3d7e90c3ab66950eb80d25049bc6f6f75b08b3da5ce0de5f3fc55d6a176a8d1fdcb19a19f7d9d137aeadcc82b214550474f76d5611bc5592ca649ddd8257a2a
diff --git a/dev-python/pytest-subtests/pytest-subtests-0.5.0.ebuild b/dev-python/pytest-subtests/pytest-subtests-0.5.0.ebuild
new file mode 100644
index 000000000000..0182bfadbb1c
--- /dev/null
+++ b/dev-python/pytest-subtests/pytest-subtests-0.5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="unittest subTest() support and subtests fixture"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-subtests/
+ https://pypi.org/project/pytest-subtests/"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-subtests/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-5.3.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions
+ ' python3_7 pypy3)
+"
+# pytest-xdist is used to test compatibility
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}