summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-08-14 19:57:56 -0700
committerPatrick McLean <chutzpah@gentoo.org>2023-08-15 12:47:35 -0700
commitd7fa918e3b8de4336d6db8cdfa5b22a5a28dfb45 (patch)
tree92631e640c898f1da3428bc5e68a2f5a741d5f98 /dev-python/pytest-system-statistics
parentdev-python/iminuit: Bump to 2.24.0 (diff)
downloadgentoo-d7fa918e3b8de4336d6db8cdfa5b22a5a28dfb45.tar.gz
gentoo-d7fa918e3b8de4336d6db8cdfa5b22a5a28dfb45.tar.bz2
gentoo-d7fa918e3b8de4336d6db8cdfa5b22a5a28dfb45.zip
dev-python/pytest-system-statistics: Revbump, add fix for loading with newer setuptools
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pytest-system-statistics')
-rw-r--r--dev-python/pytest-system-statistics/files/pytest-system-statistics-1.0.2-loader.patch43
-rw-r--r--dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r2.ebuild57
2 files changed, 100 insertions, 0 deletions
diff --git a/dev-python/pytest-system-statistics/files/pytest-system-statistics-1.0.2-loader.patch b/dev-python/pytest-system-statistics/files/pytest-system-statistics-1.0.2-loader.patch
new file mode 100644
index 000000000000..6d4751759617
--- /dev/null
+++ b/dev-python/pytest-system-statistics/files/pytest-system-statistics-1.0.2-loader.patch
@@ -0,0 +1,43 @@
+diff --git a/src/pytestsysstats/plugin.py b/src/pytestsysstats/plugin.py
+index 4009858..3067f73 100644
+--- a/src/pytestsysstats/plugin.py
++++ b/src/pytestsysstats/plugin.py
+@@ -231,20 +231,17 @@ def pytest_sessionstart(session: "Session") -> None:
+ ):
+ stats_processes_instance = StatsProcesses()
+ stats_processes_instance.add("Test Suite Run", os.getpid())
+- else:
+- stats_processes_instance = None
++ session.config.pluginmanager.register(stats_processes_instance, "sysstats-processes")
+
+- session.config.pluginmanager.register(stats_processes_instance, "sysstats-processes")
+-
+- terminalreporter = session.config.pluginmanager.getplugin(
+- "terminalreporter"
+- ) # type: "TerminalReporter"
+- sys_stats_reporter = SystemStatsReporter(
+- config=session.config,
+- stats_processes=stats_processes_instance,
+- terminalreporter=terminalreporter,
+- )
+- session.config.pluginmanager.register(sys_stats_reporter, "sysstats-reporter")
++ terminalreporter = session.config.pluginmanager.getplugin(
++ "terminalreporter"
++ ) # type: "TerminalReporter"
++ sys_stats_reporter = SystemStatsReporter(
++ config=session.config,
++ stats_processes=stats_processes_instance,
++ terminalreporter=terminalreporter,
++ )
++ session.config.pluginmanager.register(sys_stats_reporter, "sysstats-reporter")
+
+
+ @pytest.fixture(scope="session") # type: ignore[misc]
+@@ -252,5 +249,5 @@ def stats_processes(request: "SubRequest") -> StatsProcesses:
+ """
+ Session scoped process statistics tracker.
+ """
+- plugin = request.config.pluginmanager.get_plugin("sysstats-processes") # type: StatsProcesses
+- return plugin
++ if request.config.pluginmanager.has_plugin("sysstats-processes"):
++ return request.config.pluginmanager.get_plugin("sysstats-processes") # type: StatsProcesses
diff --git a/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r2.ebuild b/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r2.ebuild
new file mode 100644
index 000000000000..1b51073f1fb6
--- /dev/null
+++ b/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Pytest Plugin Which Reports System Usage Statistics"
+HOMEPAGE="
+ https://pypi.org/project/pytest-system-statistics/
+ https://github.com/saltstack/pytest-system-statistics
+"
+SRC_URI="https://github.com/saltstack/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/pytest-skip-markers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/wheel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/pytest-system-statistics-1.0.2-loader.patch"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e "s/use_scm_version=True/version='${PV}'/" -i setup.py || die
+ sed -e "/setuptools_scm/ d" -i setup.cfg || die
+ sed -e "s/tool.setuptools_scm/tool.disabled/" -i pyproject.toml || die
+
+ printf '__version__ = "${PV}"\n' > src/pytestsysstats/version.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ tests/functional/test_syststats.py::test_proc_sys_stats
+ tests/functional/test_syststats.py::test_proc_sys_stats_no_children
+ )
+ epytest
+}