summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-21 17:41:46 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-21 20:04:50 +0100
commit8837d3b4c0d018d6cee3f8410a22bc9a942bf063 (patch)
treec838f2a92d1417932fa0661bc63871a9be379000 /dev-python/pytest-xdist
parentdev-python/pygal: Bump to 3.0.4 (diff)
downloadgentoo-8837d3b4c0d018d6cee3f8410a22bc9a942bf063.tar.gz
gentoo-8837d3b4c0d018d6cee3f8410a22bc9a942bf063.tar.bz2
gentoo-8837d3b4c0d018d6cee3f8410a22bc9a942bf063.zip
dev-python/pytest-xdist: Bump to 3.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/Manifest1
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-3.5.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
index c1dfb9bd39fb..9bf70b109530 100644
--- a/dev-python/pytest-xdist/Manifest
+++ b/dev-python/pytest-xdist/Manifest
@@ -1,2 +1,3 @@
DIST pytest-xdist-3.3.1.tar.gz 77751 BLAKE2B 483774b3fefefb513cc3021c49fd816089869a885ba098588e503530ff3b2dfb77612aff80a7147ff33fd8c1fe69c4fda40133de94007e41c699ad763d112e92 SHA512 f439ff1acf65a8df025fec847602ebdc5355b2099501845f8cde3c5287299a9c3102fa6dd6fc82a30bc016893556a24b0b5409323f5db4015e77c711a7b5c59f
DIST pytest-xdist-3.4.0.tar.gz 78703 BLAKE2B a49dfcc707b4cc258c7cc26aa53f9b6b933880e55754a87f6de0fe5ca9b37cf7c5c5b52c3f04d5ad98857c3988130729510034dc3249c3c39bccf41d2c788be2 SHA512 c8ec998b3b7dc10d416406c0e421c1909e67c7bcd8479674520c0371615d131c75f59f1fb46f19c38cacdc1a42119534d66ace9ba58d0230a96f4f6baf0df185
+DIST pytest-xdist-3.5.0.tar.gz 78977 BLAKE2B 94feaa236728688a993ed89825f4ccd67abd7a520d235790bbfc629173e5918695ac500d04de642f07d323325972512e3ad95f0ae18a9ea239da8c2f167ab1a5 SHA512 1b6a896c6c69c110d1f3aa634740ffced570bbb788b3474687fef20147a5480a8681886b04db0413f7db68db546236f9a7f37e1592a74d1145f6eb6d876216ca
diff --git a/dev-python/pytest-xdist/pytest-xdist-3.5.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-3.5.0.ebuild
new file mode 100644
index 000000000000..441f239a2f03
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-3.5.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="
+ https://pypi.org/project/pytest-xdist/
+ https://github.com/pytest-dev/pytest-xdist/
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.2.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/filelock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # disable autoloading plugins in nested pytest calls
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # since we disabled autoloading, force loading necessary plugins
+ local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked
+
+ epytest
+}