summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-12 21:19:30 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-12 22:12:31 +0100
commit900e27531bbac67e3022c09cae84a42eed9ff72f (patch)
treebfe1b03b2695f9fadbb76693ae1467ec7bb98c06 /dev-python/python-bugzilla
parentapp-admin/awscli: Bump to 1.22.34 (diff)
downloadgentoo-900e27531bbac67e3022c09cae84a42eed9ff72f.tar.gz
gentoo-900e27531bbac67e3022c09cae84a42eed9ff72f.tar.bz2
gentoo-900e27531bbac67e3022c09cae84a42eed9ff72f.zip
dev-python/python-bugzilla: Bump to 3.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-bugzilla')
-rw-r--r--dev-python/python-bugzilla/Manifest1
-rw-r--r--dev-python/python-bugzilla/python-bugzilla-3.2.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/python-bugzilla/Manifest b/dev-python/python-bugzilla/Manifest
index 1ea1ea9fff12..f5a926b1b17a 100644
--- a/dev-python/python-bugzilla/Manifest
+++ b/dev-python/python-bugzilla/Manifest
@@ -1 +1,2 @@
DIST python-bugzilla-3.1.0.tar.gz 115259 BLAKE2B d3eed35aeb9778e23266fb3ce1fc477a93c09533c78e478292b90cd49668f2627d7ef47afd46973898b4d5de474399aae5e94e5cd776d5608d32325dc826c12c SHA512 8f95a60e559cc5b4576d81f37c7104d6bd4afae21986db3c5ef05c6021e601690a01ca97d67fa37e97026f0b97762594e8edd0454953e31930fa841696f65121
+DIST python-bugzilla-3.2.0.tar.gz 114279 BLAKE2B 4d2d7bfaab08dfeb4334462334f23f952b43255e656b0e39eff29bfc206529062c86c79b8c83110fbc5c3970bba40663318b65e208c1b10fb04ab6fb474eeb95 SHA512 215945a0ffd637be5567839303a738a0eef74427838bf0074a5f0ab6022306f47fc0dd5c43a3513b627fb458711f38046321ee9c2c3d43b61ffc577d6dd12375
diff --git a/dev-python/python-bugzilla/python-bugzilla-3.2.0.ebuild b/dev-python/python-bugzilla/python-bugzilla-3.2.0.ebuild
new file mode 100644
index 000000000000..a579f6e25b75
--- /dev/null
+++ b/dev-python/python-bugzilla/python-bugzilla-3.2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A python module for interacting with Bugzilla over XMLRPC"
+HOMEPAGE="https://github.com/python-bugzilla/python-bugzilla"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+
+RDEPEND="
+ || (
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ sys-apps/file[python,${PYTHON_USEDEP}]
+ )
+ dev-python/requests[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest