summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-21 16:29:52 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-21 16:34:02 +0200
commit3995555144b9edd9832c6e79eb0d57a3cd03c6d8 (patch)
treec645b68a0c332514b195ad900e8a9476ae1e21a2 /dev-python/python-engineio
parentdev-python/oslo-utils: Remove eventlet support entirely (diff)
downloadgentoo-3995555144b9edd9832c6e79eb0d57a3cd03c6d8.tar.gz
gentoo-3995555144b9edd9832c6e79eb0d57a3cd03c6d8.tar.bz2
gentoo-3995555144b9edd9832c6e79eb0d57a3cd03c6d8.zip
dev-python/python-engineio: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-engineio')
-rw-r--r--dev-python/python-engineio/Manifest2
-rw-r--r--dev-python/python-engineio/python-engineio-4.3.2-r2.ebuild67
-rw-r--r--dev-python/python-engineio/python-engineio-4.3.3.ebuild63
3 files changed, 0 insertions, 132 deletions
diff --git a/dev-python/python-engineio/Manifest b/dev-python/python-engineio/Manifest
index 718557b92d81..1dedeaffeac0 100644
--- a/dev-python/python-engineio/Manifest
+++ b/dev-python/python-engineio/Manifest
@@ -1,3 +1 @@
-DIST python-engineio-4.3.2.gh.tar.gz 299722 BLAKE2B 87dece98d72b7b0384e3b9d57062a3eaa7aeb80ac3f2f685d50b8816e122398ffd54da1f4b99a90a1f535e2d0f0d282167a682de022373e6108f7e91f8689aa1 SHA512 59933a0093167042a3873ba1561d2859359a5ad160f6b7b5c19478b1f73d1bd068779942c8bfc44dd5a8d9f155359571298b960bcd217aab341bdfec35bc5b28
-DIST python-engineio-4.3.3.gh.tar.gz 300494 BLAKE2B 302de4432717154258748602598d455650e858d3193127054abbd6d4e070255b26f38d08f620769b4782b29c43a9e6255896ff1192878c23b033168328036f90 SHA512 a8022b853c0a249e269c1e682f28d67022a2bd44975d67ea55e5244a02b540cded8042d7e9cbc5461f2a12970b64c00fa6d2e1a91ce93926fb0eace60096dccc
DIST python-engineio-4.3.4.gh.tar.gz 300665 BLAKE2B 78488fb7deb54136a255b1027e52e1869e7d09b38769d3dd144b26146ac8db58091238c3f1cfa81d4c29af4d1bd8bb998559756053e53f6c7876c2866da31575 SHA512 427f224ae24d939d55316931cd087676741195d578415224de291f9871b535fdd02b835ac32a65d73be0428c8c4be0414faefca06a4964b1fe34e2ac91b02694
diff --git a/dev-python/python-engineio/python-engineio-4.3.2-r2.ebuild b/dev-python/python-engineio/python-engineio-4.3.2-r2.ebuild
deleted file mode 100644
index 0ffd329ab1cf..000000000000
--- a/dev-python/python-engineio/python-engineio-4.3.2-r2.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Python implementation of the Engine.IO realtime server"
-HOMEPAGE="
- https://python-engineio.readthedocs.io/
- https://github.com/miguelgrinberg/python-engineio/
- https://pypi.org/project/python-engineio/"
-SRC_URI="
- https://github.com/miguelgrinberg/python-engineio/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/aiohttp[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/websocket-client[${PYTHON_USEDEP}]
-"
-# Can use eventlet, werkzeug, or gevent, but no tests for werkzeug
-# eventlet doesn't yet support Python 3.10, so let's work around it
-BDEPEND="
- test? (
- $(python_gen_cond_dep '
- dev-python/eventlet[${PYTHON_USEDEP}]
- ' python3_{8,9} )
-
- dev-python/gevent[${PYTHON_USEDEP}]
- dev-python/tornado[${PYTHON_USEDEP}]
- dev-python/websockets[${PYTHON_USEDEP}]
- )
-"
-
-EPYTEST_DESELECT=(
- # Both want websocket (server) which isn't strictly required and fails
- # because it can't find it. Think it needs right provider depending on
- # whether it chose gevent/eventlet/werkzeug. Not worth the effort.
- tests/common/test_server.py::TestServer::test_connect
- tests/common/test_server.py::TestServer::test_upgrades
-)
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- dev-python/alabaster
-
-python_test() {
- if [[ ${EPYTHON} != python3.8 && ${EPYTHON} != python3.9 ]] ; then
- EPYTEST_IGNORE+=(
- tests/common/test_async_eventlet.py
- )
-
- EPYTEST_DESELECT+=(
- tests/common/test_server.py::TestServer::test_async_mode_eventlet
- )
- fi
-
- epytest
-}
diff --git a/dev-python/python-engineio/python-engineio-4.3.3.ebuild b/dev-python/python-engineio/python-engineio-4.3.3.ebuild
deleted file mode 100644
index 11eb015d2d1d..000000000000
--- a/dev-python/python-engineio/python-engineio-4.3.3.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python implementation of the Engine.IO realtime server"
-HOMEPAGE="
- https://python-engineio.readthedocs.io/
- https://github.com/miguelgrinberg/python-engineio/
- https://pypi.org/project/python-engineio/"
-SRC_URI="
- https://github.com/miguelgrinberg/python-engineio/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/aiohttp[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/websocket-client[${PYTHON_USEDEP}]
-"
-# Can use eventlet, werkzeug, or gevent, but no tests for werkzeug
-# eventlet doesn't yet support Python 3.10, so let's work around it
-BDEPEND="
- test? (
- $(python_gen_cond_dep '
- dev-python/eventlet[${PYTHON_USEDEP}]
- ' python3_{8,9} )
-
- dev-python/gevent[${PYTHON_USEDEP}]
- dev-python/tornado[${PYTHON_USEDEP}]
- dev-python/websockets[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- dev-python/alabaster
-
-python_test() {
- if ! has_version "dev-python/eventlet[${PYTHON_USEDEP}]"; then
- EPYTEST_IGNORE+=(
- tests/common/test_async_eventlet.py
- )
-
- EPYTEST_DESELECT+=(
- tests/common/test_server.py::TestServer::test_async_mode_eventlet
- tests/common/test_server.py::TestServer::test_connect
- tests/common/test_server.py::TestServer::test_service_task_started
- tests/common/test_server.py::TestServer::test_upgrades
- )
- fi
-
- epytest
-}