summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-15 05:06:46 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-15 05:26:40 +0200
commit7b0fa93f40c3748e14e6d611c684a0cf6384258e (patch)
treeee619ed5e8de546510aa3a59677a0cd7b3aad7b4 /dev-python/python-engineio
parentdev-python/pytest-localftpserver: Bump to 1.2.0 (diff)
downloadgentoo-7b0fa93f40c3748e14e6d611c684a0cf6384258e.tar.gz
gentoo-7b0fa93f40c3748e14e6d611c684a0cf6384258e.tar.bz2
gentoo-7b0fa93f40c3748e14e6d611c684a0cf6384258e.zip
dev-python/python-engineio: Bump to 4.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-engineio')
-rw-r--r--dev-python/python-engineio/Manifest1
-rw-r--r--dev-python/python-engineio/python-engineio-4.8.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/python-engineio/Manifest b/dev-python/python-engineio/Manifest
index e7e9ab71ba9c..e943b2633277 100644
--- a/dev-python/python-engineio/Manifest
+++ b/dev-python/python-engineio/Manifest
@@ -3,3 +3,4 @@ DIST python-engineio-4.6.0.gh.tar.gz 310597 BLAKE2B 7749e65f1f79bd21fb3f89dd541f
DIST python-engineio-4.6.1.gh.tar.gz 310625 BLAKE2B 2247e926117ee659f7bd428df673b10c3655534b33d062eb33e7f400890062116f3edc82f66e6bd29817e61b314376b2227fbb513802c11a04c921a610f00063 SHA512 a423a048a09396d7a3c834056118bbd124a1313e8f63b16fa40ec51b6b8f247fbe7d540e1e5f4a8a103c14ff5b5e3f53686723f2cd70e26c3a59b6100bff336f
DIST python-engineio-4.7.0.gh.tar.gz 311878 BLAKE2B 6b33bbf8c386fd6bf02f00d66e98bb11ef7a862d0d7c796094aeeeba8c87dd41e1f5b957a786b6ef181037dd5e6c390abdafc4f91fbacae356a0dbfe736e2775 SHA512 c1a41059024939a2cd11ed235a984b4e25cb622745fd6b46f15304d1470d33214283b7ae7b097edc8312ce1b5dc144eed7a2a505042b150b7bbd4320f026cd9d
DIST python-engineio-4.7.1.gh.tar.gz 311622 BLAKE2B 101a15515aa80eb56c2285bef3f7967023cd8a2e54360c348d84af81dc4901424446b50a1d7b70ba0d6a073ee2780ccd524e61a30b1475d54b30f32494063386 SHA512 fa71efb885628b9337d3f6d20cc92ac990fadb5fafdb020904e6e2bb452957a437f6467724897729f2f9e30eb713d8ce88f254fbfe49258fa33ba38572206289
+DIST python-engineio-4.8.0.gh.tar.gz 313056 BLAKE2B 508c7303ee1020db27f7d8a26148b1748b9685f1d8fadb6abbe110e9b4acb85d6510c6bbc074ae0582efeab7c5b8e294eeed7115d34784bddd55f0b4bd20318f SHA512 351d982bf729a9747215d5845d9b547ecc5dd031cb3c32cd98d75b42374455e625ba0a8f7edf0db63354f7d905eedeb749145a851f8744571f0f2ab9d1142b47
diff --git a/dev-python/python-engineio/python-engineio-4.8.0.ebuild b/dev-python/python-engineio/python-engineio-4.8.0.ebuild
new file mode 100644
index 000000000000..d30dc486a613
--- /dev/null
+++ b/dev-python/python-engineio/python-engineio-4.8.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Engine.IO realtime server"
+HOMEPAGE="
+ https://python-engineio.readthedocs.io/
+ https://github.com/miguelgrinberg/python-engineio/
+ https://pypi.org/project/python-engineio/"
+SRC_URI="
+ https://github.com/miguelgrinberg/python-engineio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/simple-websocket-0.10.0[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+"
+# Can use eventlet, werkzeug, or gevent, but no tests for werkzeug
+BDEPEND="
+ test? (
+ dev-python/tornado[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/alabaster
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # eventlet is masked for removal
+ tests/common/test_async_eventlet.py
+ )
+
+ local EPYTEST_DESELECT=(
+ # also eventlet
+ tests/common/test_server.py::TestServer::test_async_mode_eventlet
+ tests/common/test_server.py::TestServer::test_connect
+ tests/common/test_server.py::TestServer::test_service_task_started
+ tests/common/test_server.py::TestServer::test_upgrades
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}