summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-19 12:26:04 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-19 12:26:28 +0100
commitcee3903a6c800bf09f788d72bc2737309b1edbc4 (patch)
tree05a1bdbc136298f148b7c8b959088c493f0a4c3f /dev-python/pyzmq
parentdev-python/python-vitrageclient: Remove old (diff)
downloadgentoo-cee3903a6c800bf09f788d72bc2737309b1edbc4.tar.gz
gentoo-cee3903a6c800bf09f788d72bc2737309b1edbc4.tar.bz2
gentoo-cee3903a6c800bf09f788d72bc2737309b1edbc4.zip
dev-python/pyzmq: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyzmq')
-rw-r--r--dev-python/pyzmq/Manifest1
-rw-r--r--dev-python/pyzmq/files/pyzmq-19.0.0-tests.patch186
-rw-r--r--dev-python/pyzmq/pyzmq-19.0.1_p20200608.ebuild64
3 files changed, 0 insertions, 251 deletions
diff --git a/dev-python/pyzmq/Manifest b/dev-python/pyzmq/Manifest
index 20950bd9d595..efb9b0bf0edb 100644
--- a/dev-python/pyzmq/Manifest
+++ b/dev-python/pyzmq/Manifest
@@ -1,3 +1,2 @@
-DIST pyzmq-19.0.1_p20200608.tar.gz 390927 BLAKE2B d70a2f615782cc5a53ed2ffab4d5549bc5d15cc1e0e63f640a357fe8575ca327a5976a3e8b11d97c236a31ca17025f37fe423d166b684b5c4aafc139a0941492 SHA512 7f077ed3858c226eb1e3f5e51dfb5d4b517ec94357b37cc66d17cfe2543786b86627ce7eb4c12785a2709a499af998d02642d972c119a637df3cec5201e909d1
DIST pyzmq-19.0.2.tar.gz 390927 BLAKE2B d70a2f615782cc5a53ed2ffab4d5549bc5d15cc1e0e63f640a357fe8575ca327a5976a3e8b11d97c236a31ca17025f37fe423d166b684b5c4aafc139a0941492 SHA512 7f077ed3858c226eb1e3f5e51dfb5d4b517ec94357b37cc66d17cfe2543786b86627ce7eb4c12785a2709a499af998d02642d972c119a637df3cec5201e909d1
DIST pyzmq-20.0.0.gh.tar.gz 393041 BLAKE2B 1f22f556f5d0f2755c2e56411fdb9f583bbdfad6315e4e72fbaa1fb18d0ad5436ee0ee8d17497641421cea3f4e1b53b8ff85bf7ced96c8f1c80db0be901ca3d5 SHA512 30359e501e76d6ec14175622d6c970d9ec0f227b372d2b1c6e6650be812dd47017b797a016f5a2da83f72d00536e64d2f005a38003c9a1b4fbb7266f2640782d
diff --git a/dev-python/pyzmq/files/pyzmq-19.0.0-tests.patch b/dev-python/pyzmq/files/pyzmq-19.0.0-tests.patch
deleted file mode 100644
index f56e7c6d3a5d..000000000000
--- a/dev-python/pyzmq/files/pyzmq-19.0.0-tests.patch
+++ /dev/null
@@ -1,186 +0,0 @@
-diff --git a/zmq/tests/test_auth.py b/zmq/tests/test_auth.py
-index 003f171..9d882b6 100644
---- a/zmq/tests/test_auth.py
-+++ b/zmq/tests/test_auth.py
-@@ -191,6 +191,7 @@ class TestThreadAuthentication(BaseAuthTestCase):
- client.close()
- server.close()
-
-+ @pytest.mark.skip("sometimes hangs")
- def test_curve(self):
- """threaded auth - CURVE"""
- self.auth.allow('127.0.0.1')
-@@ -309,6 +310,7 @@ class TestThreadAuthentication(BaseAuthTestCase):
-
-
- @skip_pypy
-+ @pytest.mark.skip("fails with cffi")
- def test_curve_user_id(self):
- """threaded auth - CURVE"""
- self.auth.allow('127.0.0.1')
-diff --git a/zmq/tests/test_constants.py b/zmq/tests/test_constants.py
-index 6b4d0c9..d527b06 100644
---- a/zmq/tests/test_constants.py
-+++ b/zmq/tests/test_constants.py
-@@ -91,6 +91,7 @@ class TestConstants(TestCase):
- self.fail("Shouldn't have: zmq.%s=%s" % (name, value))
-
- @pytest.mark.skipif(not zmq.DRAFT_API, reason="Only test draft API if built with draft API")
-+ @pytest.mark.skip("fails with cffi")
- def test_draft(self):
- zmq_version = zmq.zmq_version_info()
- for version, new_names in constant_names.draft_in.items():
-diff --git a/zmq/tests/test_draft.py b/zmq/tests/test_draft.py
-index 5bb9e29..934ed50 100644
---- a/zmq/tests/test_draft.py
-+++ b/zmq/tests/test_draft.py
-@@ -20,6 +20,7 @@ class TestDraftSockets(BaseZMQTestCase):
- super(TestDraftSockets, self).setUp()
-
-
-+ @pytest.mark.skip("fails with cffi")
- def test_client_server(self):
- client, server = self.create_bound_pair(zmq.CLIENT, zmq.SERVER)
- client.send(b'request')
-@@ -29,6 +30,7 @@ class TestDraftSockets(BaseZMQTestCase):
- reply = self.recv(client)
- assert reply == b'reply'
-
-+ @pytest.mark.skip("fails with cffi")
- def test_radio_dish(self):
- dish, radio = self.create_bound_pair(zmq.DISH, zmq.RADIO)
- dish.rcvtimeo = 250
-diff --git a/zmq/tests/test_message.py b/zmq/tests/test_message.py
-index d3a6aa8..9ce622c 100644
---- a/zmq/tests/test_message.py
-+++ b/zmq/tests/test_message.py
-@@ -18,6 +18,7 @@ import zmq
- from zmq.tests import BaseZMQTestCase, SkipTest, skip_pypy, PYPY
- from zmq.utils.strtypes import unicode, bytes, b, u
-
-+import pytest
-
- # some useful constants:
-
-@@ -71,7 +72,7 @@ class TestFrame(BaseZMQTestCase):
- m = zmq.Frame(s)
- b = m.bytes
- self.assertEqual(s, m.bytes)
-- if not PYPY:
-+ if not PYPY and False:
- # check that it copies
- self.assert_(b is not s)
- # check that it copies only once
-@@ -94,6 +95,7 @@ class TestFrame(BaseZMQTestCase):
- self.assertEqual(len(s), len(m))
-
- @skip_pypy
-+ @pytest.mark.skip("seems to be broken")
- def test_lifecycle1(self):
- """Run through a ref counting cycle with a copy."""
- for i in range(5, 16): # 32, 64,..., 65536
-@@ -130,6 +132,7 @@ class TestFrame(BaseZMQTestCase):
- del s
-
- @skip_pypy
-+ @pytest.mark.skip("seems to be broken")
- def test_lifecycle2(self):
- """Run through a different ref counting cycle with a copy."""
- for i in range(5, 16): # 32, 64,..., 65536
-@@ -166,6 +169,7 @@ class TestFrame(BaseZMQTestCase):
- del s
-
- @skip_pypy
-+ @pytest.mark.skip("fails with cffi")
- def test_tracker(self):
- m = zmq.Frame(b'asdf', copy=False, track=True)
- self.assertFalse(m.tracker.done)
-@@ -186,6 +190,7 @@ class TestFrame(BaseZMQTestCase):
- self.assertRaises(ValueError, zmq.MessageTracker, m)
-
- @skip_pypy
-+ @pytest.mark.skip("fails with cffi")
- def test_multi_tracker(self):
- m = zmq.Frame(b'asdf', copy=False, track=True)
- m2 = zmq.Frame(b'whoda', copy=False, track=True)
-@@ -222,6 +227,7 @@ class TestFrame(BaseZMQTestCase):
- self.assert_(m.buffer is m.buffer)
-
- @skip_pypy
-+ @pytest.mark.skip("fails with cffi")
- def test_memoryview_shape(self):
- """memoryview shape info"""
- if sys.version_info < (3,):
-@@ -331,6 +337,7 @@ class TestFrame(BaseZMQTestCase):
- B = numpy.frombuffer(msg, A.dtype).reshape(A.shape)
- assert_array_equal(A, B)
-
-+ @pytest.mark.skip("fails with cffi")
- def test_frame_more(self):
- """test Frame.more attribute"""
- frame = zmq.Frame(b"hello")
-diff --git a/zmq/tests/test_security.py b/zmq/tests/test_security.py
-index b73234d..8fdea48 100644
---- a/zmq/tests/test_security.py
-+++ b/zmq/tests/test_security.py
-@@ -9,6 +9,8 @@ import contextlib
- import time
- from threading import Thread
-
-+import pytest
-+
- import zmq
- from zmq.tests import (
- BaseZMQTestCase, SkipTest, PYPY
-@@ -114,6 +116,7 @@ class TestSecurity(BaseZMQTestCase):
- client.connect("%s:%i" % (iface, port))
- self.bounce(server, client, False)
-
-+ @pytest.mark.skip("fails with cffi")
- def test_plain(self):
- """test PLAIN authentication"""
- server = self.socket(zmq.DEALER)
-@@ -201,6 +204,7 @@ class TestSecurity(BaseZMQTestCase):
- # verify that it is equal to the known public key
- self.assertEqual(derived_public, public)
-
-+ @pytest.mark.skip("fails with cffi")
- def test_curve(self):
- """test CURVE encryption"""
- server = self.socket(zmq.DEALER)
-diff --git a/zmq/tests/test_socket.py b/zmq/tests/test_socket.py
-index 3046663..dcc66d0 100644
---- a/zmq/tests/test_socket.py
-+++ b/zmq/tests/test_socket.py
-@@ -221,6 +221,7 @@ class TestSocket(BaseZMQTestCase):
- self.assertEqual(rcvd, [b'b'])
-
- @skip_pypy
-+ @pytest.mark.skip("test hangs")
- def test_tracker(self):
- "test the MessageTracker object for tracking when zmq is done with a buffer"
- addr = 'tcp://127.0.0.1'
-@@ -363,6 +364,7 @@ class TestSocket(BaseZMQTestCase):
- s.close()
- self.assertTrue(s.closed)
-
-+ @pytest.mark.skip("fails with cffi")
- def test_poll(self):
- a,b = self.create_bound_pair()
- tic = time.time()
-@@ -502,6 +504,7 @@ class TestSocket(BaseZMQTestCase):
- self.assertEqual(events, [])
-
- # Travis can't handle how much memory PyPy uses on this test
-+ @pytest.mark.skip("test hangs")
- @mark.skipif(
- (
- pypy and on_travis
-@@ -536,6 +539,7 @@ class TestSocket(BaseZMQTestCase):
- assert view[0] == byte
- assert view[-1] == byte
-
-+ @pytest.mark.skip("fails with cffi")
- def test_custom_serialize(self):
- a, b = self.create_bound_pair(zmq.DEALER, zmq.ROUTER)
- def serialize(msg):
diff --git a/dev-python/pyzmq/pyzmq-19.0.1_p20200608.ebuild b/dev-python/pyzmq/pyzmq-19.0.1_p20200608.ebuild
deleted file mode 100644
index 9b8e49085f08..000000000000
--- a/dev-python/pyzmq/pyzmq-19.0.1_p20200608.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit flag-o-matic distutils-r1 toolchain-funcs
-
-EGIT_COMMIT="dd4dac055152d47c829034224cdecf594c7b3f12"
-DESCRIPTION="Lightweight and super-fast messaging library built on top of the ZeroMQ library"
-HOMEPAGE="
- https://www.zeromq.org/bindings:python
- https://pypi.org/project/pyzmq/
- https://github.com/zeromq/pyzmq/"
-SRC_URI="
- https://github.com/zeromq/pyzmq/archive/${EGIT_COMMIT}.tar.gz
- -> ${P}.tar.gz"
-S=${WORKDIR}/${PN}-${EGIT_COMMIT}
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~mips ~ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="+draft"
-
-DEPEND="
- >=net-libs/zeromq-4.2.2-r2:=[drafts]
-"
-RDEPEND="${DEPEND}
- dev-python/py[${PYTHON_USEDEP}]
- dev-python/cffi:=[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- test? (
- >=www-servers/tornado-5.0.2[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/pyzmq-19.0.0-tests.patch"
-)
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- "dev-python/numpydoc"
-
-python_prepare_all() {
- # probably broken with new numpy
- sed -i -e 's:test_buffer_numpy:_&:' zmq/tests/test_message.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- tc-export CC
- append-cppflags -DZMQ_BUILD_DRAFT_API=$(usex draft '1' '0')
-}
-
-python_compile() {
- esetup.py cython --force
- distutils-r1_python_compile
-}