summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-14 19:05:31 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-14 19:13:35 +0200
commitf8438c95011d2a2148f9b685901ee929f453f183 (patch)
tree27268aa311bd6a24ad0e09762c3aba323815e7a6 /dev-python/rich/rich-13.7.1.ebuild
parentdev-python/httpcore: Enable py3.13 (diff)
downloadgentoo-f8438c95011d2a2148f9b685901ee929f453f183.tar.gz
gentoo-f8438c95011d2a2148f9b685901ee929f453f183.tar.bz2
gentoo-f8438c95011d2a2148f9b685901ee929f453f183.zip
dev-python/rich: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rich/rich-13.7.1.ebuild')
-rw-r--r--dev-python/rich/rich-13.7.1.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/dev-python/rich/rich-13.7.1.ebuild b/dev-python/rich/rich-13.7.1.ebuild
index de4ea8ee4fa4..a5c3df268492 100644
--- a/dev-python/rich/rich-13.7.1.ebuild
+++ b/dev-python/rich/rich-13.7.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1 optfeature
@@ -45,6 +45,18 @@ python_test() {
tests/test_inspect.py::test_inspect_integer_with_methods_python310only
)
;;
+ python3.13)
+ EPYTEST_DESELECT+=(
+ tests/test_inspect.py::test_inspect_builtin_function_except_python311
+ tests/test_inspect.py::test_inspect_integer_with_methods_python38_and_python39
+ tests/test_inspect.py::test_inspect_integer_with_methods_python310only
+ tests/test_inspect.py::test_inspect_integer_with_methods_python311
+ tests/test_pretty.py::test_pretty_dataclass
+ tests/test_pretty.py::test_reference_cycle_dataclass
+ tests/test_pretty.py::test_max_depth_dataclass
+ tests/test_pretty.py::test_attrs_broken
+ )
+ ;;
esac
local -x COLUMNS=80