summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-21 13:45:12 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-21 15:34:57 +0200
commiteaf8e171b287b2b5576040bcf2da48e1298ac148 (patch)
tree3c5d37d7d6176cd3f8ce5c73b99fcaf86b84b3d7 /dev-python/rq
parentdev-python/sqlparse: Force pytest<6 (diff)
downloadgentoo-eaf8e171b287b2b5576040bcf2da48e1298ac148.tar.gz
gentoo-eaf8e171b287b2b5576040bcf2da48e1298ac148.tar.bz2
gentoo-eaf8e171b287b2b5576040bcf2da48e1298ac148.zip
dev-python/rq: Bump to 1.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rq')
-rw-r--r--dev-python/rq/Manifest1
-rw-r--r--dev-python/rq/rq-1.5.1.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/rq/Manifest b/dev-python/rq/Manifest
index 0d6a8a052910..fc1c7241d1dd 100644
--- a/dev-python/rq/Manifest
+++ b/dev-python/rq/Manifest
@@ -1,2 +1,3 @@
DIST rq-1.4.3.tar.gz 52258 BLAKE2B fd2bb19239ac3011005b34cf041e7736794a27b2097a7ff1808a716d45ad224ad349e316f172308175174f59ff0d3d2bbe0c6778bd66cdad6755da2740898c0d SHA512 177c748148a109efaeddf14b3847e7980882f385ba0e346ccfa72983d584f1c739417383c6eec83370a66f1ceeb5f955de9d5ccf87e4136074aa52e2f9144bd3
DIST rq-1.5.0.tar.gz 569320 BLAKE2B 5349f6e806c5348e584513bf8fe8828c44909b8f4e53fcdfe40e0c617f162859dbc89d4595993c29227a25cef5b6ddbb758c51c3e50b442ada62eaca0585490a SHA512 87eb83de529afe3a1e0a9f2b1727aba97482e3e55024aede29ad6e12ed5b92ca147bef8d720a09b34939c04ac5e37642147aea5b1b7686ed4b2aaacdcf998f6d
+DIST rq-1.5.1.tar.gz 569967 BLAKE2B 9de43fa2d88a58186e8889163f4c1ea92da068c3652c5e32008a39c0e3b27e06f4a1c696a88d1dbf5b05d280bff9c1c56a1995673e9d0ff3fb3a50498729e96b SHA512 2a03b79c7f1b253e2974007616ad3342e0b98ef9f57b0ca9dd41ecb4319074cec3ae4ba5f8958f54a1c2a6342062d74a33ec6d03689f3a89074854483af74b4f
diff --git a/dev-python/rq/rq-1.5.1.ebuild b/dev-python/rq/rq-1.5.1.ebuild
new file mode 100644
index 000000000000..d62e57cf1504
--- /dev/null
+++ b/dev-python/rq/rq-1.5.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="simple, lightweight library for creating and processing background jobs"
+HOMEPAGE="https://python-rq.org https://github.com/rq/rq"
+SRC_URI="https://github.com/rq/rq/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/sentry-sdk[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ >=dev-python/click-5.0[${PYTHON_USEDEP}]
+ >=dev-python/redis-py-3.5.0[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.5.0-no-install-tests.patch"
+)
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+ local redis_test_config="daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ "
+
+ # Spawn Redis itself for testing purposes
+ # NOTE: On sam@'s machine, spawning Redis can hang in the sandbox.
+ # I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
+ elog "Spawning Redis"
+ elog "NOTE: Port ${redis_port} must be free"
+ /usr/sbin/redis-server - <<< "${redis_test_config}" || die
+
+ # Run the actual tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}
+
+python_test() {
+ # Tests needing rqworker:
+ # TestWorkerSubprocess::test_run_access_self, test_run_empty_queue, test_run_scheduled_access_self
+ distutils_install_for_testing
+ PATH="${BUILD_DIR}/test/scripts/:${PATH}" pytest -vv || die "Testsuite failed under ${EPYTHON}"
+}