summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-18 05:50:59 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-18 06:18:34 +0100
commit1205bb342d4c8bc07d33716b58034aa1e2abbbad (patch)
treed881da9e5e93364dbd2ffefa9720a6554af089b3 /dev-python/sabctools
parentdev-python/markdown2: Bump to 2.4.12 (diff)
downloadgentoo-1205bb342d4c8bc07d33716b58034aa1e2abbbad.tar.gz
gentoo-1205bb342d4c8bc07d33716b58034aa1e2abbbad.tar.bz2
gentoo-1205bb342d4c8bc07d33716b58034aa1e2abbbad.zip
dev-python/sabctools: Bump to 8.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sabctools')
-rw-r--r--dev-python/sabctools/Manifest1
-rw-r--r--dev-python/sabctools/sabctools-8.0.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/sabctools/Manifest b/dev-python/sabctools/Manifest
index ab1f7ab5ad89..9ed9a645a6d3 100644
--- a/dev-python/sabctools/Manifest
+++ b/dev-python/sabctools/Manifest
@@ -2,3 +2,4 @@ DIST sabctools-7.0.2.gh.tar.gz 8539819 BLAKE2B 38212656c745238f106fbc9334f6dccb0
DIST sabctools-7.1.1.gh.tar.gz 8963314 BLAKE2B 583ac11ba8f4ef9d0f9d04a1697bb7e09644f2edfa851e175bf6454600e2d78bfb593c2fd3696ee077f3243084c90faa276eddd21578122233090be905367d55 SHA512 461f554d4e0032b4a4b0eaa4801d45cd014be00b5cd2f2c13ed7686d20994bb111c80fe8486a50af5622b3977056bd12d2465922f7daccd04a92af7101e52e0f
DIST sabctools-7.1.2.gh.tar.gz 8963375 BLAKE2B a404780c40cd98a605af58a79c9ecf7c5e479460db925c34486bc36621e749dcad363225e7a73e0222cc30b7bba8747d5d21ed4ac240c5df75485a2bd620e962 SHA512 7887ff3f6b46bd538540b591ab7b47a7b3efa277b45d69ed7329252b1f7326adfa6b286cc207a4262002a802c6acff03c0df4792e099da3dd8be1c3dd68a1ae0
DIST sabctools-8.0.0.gh.tar.gz 8963761 BLAKE2B d6977c399801653bcc04136c614257a8dba952129ff87a06064518796bb4de1bf340b3f5ba1e841d05c33be804232cedc38da46991b69451661a89fcb2e2ede9 SHA512 0a1e17bbb316271fa620b037cd71a88b7a424206471766f8b77c81db7d7f2828fb58518916e51d4a3aa29f0615c31fd1da615f1b67838a31ee985c13b3045257
+DIST sabctools-8.0.1.gh.tar.gz 8963513 BLAKE2B 40fbd230c40b72f1a74e255f0b715f476c52b8d75c04bac9e5131065e1cb431581debc5bec9fac5060f172ed7ccd1ae282e6ed3fe93d2c24abef064fa9918b84 SHA512 170ccfec6807165954322a58910c1aaf368acc600b4cca10abd69e1b1859ff0d52058a846a0a0e3ebbdde93d6a7079efa418dd2453e73496f043c26532b64af2
diff --git a/dev-python/sabctools/sabctools-8.0.1.ebuild b/dev-python/sabctools/sabctools-8.0.1.ebuild
new file mode 100644
index 000000000000..a500ef55dcbb
--- /dev/null
+++ b/dev-python/sabctools/sabctools-8.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_PN="sabctools"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Module providing raw yEnc encoding/decoding for SABnzbd"
+HOMEPAGE="
+ https://github.com/sabnzbd/sabctools/
+ https://pypi.org/project/sabctools/
+"
+SRC_URI="
+ https://github.com/sabnzbd/${MY_PN}/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/portend[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.md doc/yenc-draft.1.3.txt )
+
+distutils_enable_tests pytest