summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-21 03:51:35 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-21 03:55:01 +0200
commit3534dd87d4490b13823b63a2285e1ed45f85c447 (patch)
treec95dfa218e2426f4ad24f7904170532512c7dac4 /dev-python/selenium
parentdev-python/cfn-lint: Bump to 1.3.2 (diff)
downloadgentoo-3534dd87d4490b13823b63a2285e1ed45f85c447.tar.gz
gentoo-3534dd87d4490b13823b63a2285e1ed45f85c447.tar.bz2
gentoo-3534dd87d4490b13823b63a2285e1ed45f85c447.zip
dev-python/selenium: Bump to 4.22.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/selenium')
-rw-r--r--dev-python/selenium/Manifest2
-rw-r--r--dev-python/selenium/selenium-4.22.0.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/selenium/Manifest b/dev-python/selenium/Manifest
index 2581d0c25be8..5bf29a9a913b 100644
--- a/dev-python/selenium/Manifest
+++ b/dev-python/selenium/Manifest
@@ -1,2 +1,4 @@
DIST selenium-4.21.0.tar.gz 9238881 BLAKE2B 6aadfb383aabb730dd9a39dc526a7b109d640997b1ba5e486687c4e3f056a6dee624c88ed437b40c6e63689a533a5990e14e0d57afe2ed927bf9f3e4a1573266 SHA512 e5486a411aeaffb26be2f50a874c622bcd6d004cb821444c580ef5fc3e74fbc0575d00ced5f4e57b3bf75e0920eb835a423e6e8d8cf354c729d3036bfb170dec
+DIST selenium-4.22.0.tar.gz 9242392 BLAKE2B 15197221a53c597b412f805eed7f29f4c34a9d0596a069ea5a6df540b93c013815a59fe1730e8493f5ae854cbc03d5a6647eb57d825ecc68ad0b31949448acaa SHA512 a25c892495ed613c2cd96ab971f46cc101416a4928cffceaa9891c759a41d51df392999495d442a21b459d83a1b287c64c2cd5405b82e16464b56fcc75b2c595
DIST selenium-selenium-4.21.0.gh.tar.gz 77070811 BLAKE2B b9aacaf5f6091f49c4f0a6c7dca3fb5791297af8e1a8b6fa6b8e6d77fa5249d9b3c74d6c73a5aa9f443fefc3a613e0b6a12ced1f400d93c99a43b5614a6edda8 SHA512 15f25efc893fd57ef0ca21e3598c1ae976043fd8000275ff9bed117ff0c9e9c402ed1bc3fff119a511336b0e26343c6e36450b3ef49cad2dda3b1cea039ec6a7
+DIST selenium-selenium-4.22.0.gh.tar.gz 77094998 BLAKE2B 1d74be914debec94e3b9fe41ce40e7432426c7f30a848c63ad82e616fc3dd7dce8e544c33a90e28ca268988b9035aabe41805277085095cc1c65bd38e09117e5 SHA512 f71721b614fa3e346a75ca2391fb03067520d746e1433a75ba896eb6bbe621064bcab7d50337989ccb60d13c493e2df2b3b1bd73cc8dcaf3b62dc4f4ebfaa086
diff --git a/dev-python/selenium/selenium-4.22.0.ebuild b/dev-python/selenium/selenium-4.22.0.ebuild
new file mode 100644
index 000000000000..e5f0a6117408
--- /dev/null
+++ b/dev-python/selenium/selenium-4.22.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_TESTED=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" python3_13 )
+
+inherit distutils-r1 pypi
+
+# upstream sometimes tags it as ${P}, sometimes as ${P}-python, sigh
+TEST_TAG=${P}
+TEST_P=selenium-${TEST_TAG}
+
+DESCRIPTION="Python language binding for Selenium Remote Control"
+HOMEPAGE="
+ https://www.seleniumhq.org/
+ https://github.com/SeleniumHQ/selenium/tree/trunk/py/
+ https://pypi.org/project/selenium/
+"
+SRC_URI+="
+ test? (
+ https://github.com/SeleniumHQ/selenium/archive/${TEST_TAG}.tar.gz
+ -> ${TEST_P}.gh.tar.gz
+ )
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/certifi-2021.10.8[${PYTHON_USEDEP}]
+ <dev-python/trio-1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.17[${PYTHON_USEDEP}]
+ <dev-python/trio-websocket-1[${PYTHON_USEDEP}]
+ >=dev-python/trio-websocket-0.9[${PYTHON_USEDEP}]
+ <dev-python/typing-extensions-5[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.9[${PYTHON_USEDEP}]
+ <dev-python/urllib3-3[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ if ! has "${EPYTHON/./_}" "${PYTHON_TESTED[@]}"; then
+ einfo "Skipping tests on ${EPYTHON}"
+ return
+ fi
+
+ local EPYTEST_DESELECT=(
+ # TODO: we may need extra setup or deps
+ test/selenium
+
+ # expects vanilla certifi
+ test/unit/selenium/webdriver/remote/remote_connection_tests.py::test_get_connection_manager_for_certs_and_timeout
+ )
+
+ cd "${WORKDIR}/${TEST_P}/py" || die
+ rm -rf selenium || die
+ # https://github.com/SeleniumHQ/selenium/blob/selenium-4.8.2-python/py/test/runner/run_pytest.py#L20-L24
+ # seriously?
+ epytest -o "python_files=*_tests.py test_*.py"
+}