summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-06-29 08:43:08 +0200
committerMichał Górny <mgorny@gentoo.org>2019-06-29 10:15:32 +0200
commit584433f968a81aeb0eeabeda79d1d505fa6f5f02 (patch)
treea87c3322f22f9c31b96e9361ec428d0449b8fc57 /dev-python/serpent
parentdev-lang/spidermonkey: stable 1.8.5-r7 for hppa, bug #687072 (diff)
downloadgentoo-584433f968a81aeb0eeabeda79d1d505fa6f5f02.tar.gz
gentoo-584433f968a81aeb0eeabeda79d1d505fa6f5f02.tar.bz2
gentoo-584433f968a81aeb0eeabeda79d1d505fa6f5f02.zip
dev-python/serpent: Bump to 1.28
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/serpent')
-rw-r--r--dev-python/serpent/Manifest1
-rw-r--r--dev-python/serpent/serpent-1.28.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/serpent/Manifest b/dev-python/serpent/Manifest
index 98e0c6e040eb..d74f9e773c7d 100644
--- a/dev-python/serpent/Manifest
+++ b/dev-python/serpent/Manifest
@@ -1 +1,2 @@
DIST serpent-1.19.tar.gz 12055 BLAKE2B 1adf86abf58b4afb82a9d2ee3b8fff4107f3e1cd383a33359687b80b2b917ec1af8f15cb5b849c0979035daecf2aaaf1230553a478e59480f160d8df456b5fd2 SHA512 9adac06bb63dfa73ca0043a3ddf868e0afebc81ff7d637e41667314cbe8e0ecb2af807db6c60f5a5a6a6ff8fa11ac42063d83a7376c7e8bcac22abfd3ba5b1dd
+DIST serpent-1.28.tar.gz 26912 BLAKE2B 7608e1a25b4157b8e304fe6e2265f0204a3056c752a58ac0c7eaafe41b4fed9246792147a8af87dcadf5c6e94d3d494f7b561a073e1bf91e412b60a286b00a10 SHA512 776bc497c7cd815c4ef44107bdf53b62bb92229beba0be7efceb9fba57dc7c677bf09832db335485df3e466acdffe6ebf4b3636ae9b49e60075379a7419a29ad
diff --git a/dev-python/serpent/serpent-1.28.ebuild b/dev-python/serpent/serpent-1.28.ebuild
new file mode 100644
index 000000000000..44dc1e5ccf25
--- /dev/null
+++ b/dev-python/serpent/serpent-1.28.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple serialization library based on ast.literal_eval"
+HOMEPAGE="https://pypi.org/project/serpent/ https://github.com/irmen/Serpent"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}