summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/socketpool
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/socketpool')
-rw-r--r--dev-python/socketpool/Manifest2
-rw-r--r--dev-python/socketpool/files/socketpool-0.5.2-locale.patch21
-rw-r--r--dev-python/socketpool/files/socketpool-0.5.2-pool.patch35
-rw-r--r--dev-python/socketpool/metadata.xml13
-rw-r--r--dev-python/socketpool/socketpool-0.5.2-r1.ebuild37
-rw-r--r--dev-python/socketpool/socketpool-0.5.2.ebuild33
-rw-r--r--dev-python/socketpool/socketpool-0.5.3.ebuild32
7 files changed, 173 insertions, 0 deletions
diff --git a/dev-python/socketpool/Manifest b/dev-python/socketpool/Manifest
new file mode 100644
index 000000000000..b59a0f745628
--- /dev/null
+++ b/dev-python/socketpool/Manifest
@@ -0,0 +1,2 @@
+DIST socketpool-0.5.2.tar.gz 10351 SHA256 5f381048763e26d59ccd8343c2c349c06117ce09154e24f777d8364a1f5d0036 SHA512 6600719ad8cd70f4085f65b364594f3aa118a8c3b8e2cbfb7af43d09fca9a42858b67d95f0499b74f1f3bf7dcb163bf8f3500e705f147a3009accc8c4a44528d WHIRLPOOL 799d424483d090cce1f0cb7392aea755d0aebe5221d731030688d105f5e9efca428eb6d3fa1cc106daa3033ce9bd9a5bcd893d7293bd15120ab8948fa31969df
+DIST socketpool-0.5.3.tar.gz 9793 SHA256 a06733434a56c4b60b8fcaa168102d2386253d36425804d55532a6bbbda6e2ec SHA512 6d16a18927672157703fb5a29f4332241f9ddf743dfee8f2606d600dbb75d547f2e0dcc0398febe55df3319829a80b3f537b5877679e4f674569ef55de78c1b7 WHIRLPOOL 048693619a9813d97a82408ca26c66e847fa4710fc6051379a36e26f32f0310ae33561a6e2529a584e14795de577ce424af5b793fd4fbae9aa53c324c437fa85
diff --git a/dev-python/socketpool/files/socketpool-0.5.2-locale.patch b/dev-python/socketpool/files/socketpool-0.5.2-locale.patch
new file mode 100644
index 000000000000..aa0af681a768
--- /dev/null
+++ b/dev-python/socketpool/files/socketpool-0.5.2-locale.patch
@@ -0,0 +1,21 @@
+diff -ur socketpool-0.5.2.orig/setup.py socketpool-0.5.2/setup.py
+--- socketpool-0.5.2.orig/setup.py 2012-08-05 12:33:47.000000000 +0800
++++ socketpool-0.5.2/setup.py 2013-02-05 00:22:13.685705089 +0800
+@@ -5,7 +5,7 @@
+ # See the NOTICE for more information.
+
+
+-import os
++import os, io
+ from setuptools import setup, find_packages
+
+ CLASSIFIERS = [
+@@ -22,7 +22,7 @@
+
+
+ # read long description
+-with open(os.path.join(os.path.dirname(__file__), 'README.rst')) as f:
++with io.open(os.path.join(os.path.dirname(__file__), 'README.rst'), encoding='utf8') as f:
+ long_description = f.read()
+
+ DATA_FILES = [
diff --git a/dev-python/socketpool/files/socketpool-0.5.2-pool.patch b/dev-python/socketpool/files/socketpool-0.5.2-pool.patch
new file mode 100644
index 000000000000..b6ce4965d041
--- /dev/null
+++ b/dev-python/socketpool/files/socketpool-0.5.2-pool.patch
@@ -0,0 +1,35 @@
+patch made from https://github.com/benoitc/socketpool/blob/06d659612f15cb4c207a2fc508b6099e09d3fde7/socketpool/pool.py
+in reply to; size is supposed to be a property. fix #20
+commit 06d659612f15cb4c207a2fc508b6099e09d3fde7.
+file included changes making the first hunk
+diff -ur socketpool-0.5.2.orig/socketpool/pool.py socketpool-0.5.2/socketpool/pool.py
+--- socketpool/pool.py 2012-08-05 12:22:13.000000000 +0800
++++ socketpool/pool.py 2013-02-10 22:51:45.607637365 +0800
+@@ -48,8 +48,12 @@
+ max_size=10, options=None,
+ reap_connections=True, backend="thread"):
+
+- self.backend_mod = load_backend(backend)
+- self.backend = backend
++ if isinstance(backend, str):
++ self.backend_mod = load_backend(backend)
++ self.backend = backend
++ else:
++ self.backend_mod = backend
++ self.backend = str(getattr(backend, '__name__', backend))
+ self.max_size = max_size
+ self.pool = getattr(self.backend_mod, 'PriorityQueue')()
+ self._free_conns = 0
+@@ -97,6 +101,7 @@
+ if conn.is_connected():
+ conn.invalidate()
+
++ @property
+ def size(self):
+ return self.pool.qsize()
+
+@@ -193,3 +198,4 @@
+ finally:
+ self.release_connection(conn)
+
++
diff --git a/dev-python/socketpool/metadata.xml b/dev-python/socketpool/metadata.xml
new file mode 100644
index 000000000000..5d682bb96d18
--- /dev/null
+++ b/dev-python/socketpool/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>idella4@gentoo.org</email>
+ <name>Ian Delaney</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">socketpool</remote-id>
+ <remote-id type="github">benoitc/socketpool</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/socketpool/socketpool-0.5.2-r1.ebuild b/dev-python/socketpool/socketpool-0.5.2-r1.ebuild
new file mode 100644
index 000000000000..df3dbb514d9d
--- /dev/null
+++ b/dev-python/socketpool/socketpool-0.5.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3} pypy )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A simple Python socket pool"
+HOMEPAGE="http://github.com/benoitc/socketpool/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="examples"
+LICENSE="|| ( MIT public-domain )"
+SLOT="0"
+
+RDEPEND="dev-python/gevent"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}"/${P}-locale.patch
+ "${FILESDIR}"/${P}-pool.patch )
+
+src_install() {
+ distutils-r1_src_install
+ if use examples; then
+ docompress -x usr/share/doc/${P}/examples
+ insinto usr/share/doc/${P}
+ doins -r examples/
+ fi
+}
+
+python_test() {
+ PYTHONPATH=. py.test tests/test_pool_01.py
+}
diff --git a/dev-python/socketpool/socketpool-0.5.2.ebuild b/dev-python/socketpool/socketpool-0.5.2.ebuild
new file mode 100644
index 000000000000..45e2e7bd5084
--- /dev/null
+++ b/dev-python/socketpool/socketpool-0.5.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple Python socket pool"
+HOMEPAGE="http://github.com/benoitc/socketpool/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+LICENSE="|| ( MIT public-domain )"
+SLOT="0"
+
+RDEPEND="dev-python/gevent"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_install() {
+ distutils-r1_src_install
+ if use examples; then
+ docompress -x usr/share/doc/${P}/examples
+ insinto usr/share/doc/${P}
+ doins -r examples/
+ fi
+}
+src_test() {
+ PYTHONPATH=. py.test tests/test_pool_01.py
+}
diff --git a/dev-python/socketpool/socketpool-0.5.3.ebuild b/dev-python/socketpool/socketpool-0.5.3.ebuild
new file mode 100644
index 000000000000..bd6296d61001
--- /dev/null
+++ b/dev-python/socketpool/socketpool-0.5.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple Python socket pool"
+HOMEPAGE="http://github.com/benoitc/socketpool/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="amd64 arm ppc ppc64 x86"
+IUSE="examples test"
+LICENSE="|| ( MIT public-domain )"
+SLOT="0"
+
+RDEPEND="$(python_gen_cond_dep 'dev-python/gevent[${PYTHON_USEDEP}]' 'python2*')"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.5.2-locale.patch )
+
+python_test() {
+ py.test tests || die
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}