summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-08-02 02:17:03 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-08-02 04:06:24 +0000
commitc842d7e80a69f6dbf78eff04777de7ec1646ba39 (patch)
tree9ca57e7b82545571936f1ec7486f63b16e46fbb0 /dev-python/sphinxcontrib-napoleon
parentdev-python/pockets: version bump (diff)
downloadgentoo-c842d7e80a69f6dbf78eff04777de7ec1646ba39.tar.gz
gentoo-c842d7e80a69f6dbf78eff04777de7ec1646ba39.tar.bz2
gentoo-c842d7e80a69f6dbf78eff04777de7ec1646ba39.zip
dev-python/sphinxcontrib-napoleon: version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/sphinxcontrib-napoleon')
-rw-r--r--dev-python/sphinxcontrib-napoleon/Manifest1
-rw-r--r--dev-python/sphinxcontrib-napoleon/sphinxcontrib-napoleon-0.6.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-napoleon/Manifest b/dev-python/sphinxcontrib-napoleon/Manifest
index 39fc74bc8a27..4f73eaf3553d 100644
--- a/dev-python/sphinxcontrib-napoleon/Manifest
+++ b/dev-python/sphinxcontrib-napoleon/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib-napoleon-0.5.2.tar.gz 24939 SHA256 3babaf7da3d062a2feba71f747946d123187e12ef68329eb6974026b25d218b8 SHA512 5f8d31c4ce66a042aa0c79ec06b7592539154bd7a397c1898db0cbed15b9891c908bb1d51334ef0b759e5d44ac99cf124616f0e4b3a1b1253f0f92312c949a8c WHIRLPOOL e577861c4357719a75ef84166f4cb9059fadded3b629606674beb5bfbd242bf4efb15c2889731690f4be8555b7561fb7c7ded14df925ebc2d926f26c91889bf4
+DIST sphinxcontrib-napoleon-0.6.1.tar.gz 20057 SHA256 614b779888629f14dfdfad6c17bffbb6d3813a0a0917a9541651d85384d4d6bd SHA512 1809fcadf964622bd75cc3ae17aaad467b7003f82e6df4de039a0ba86daa5c5b199af0c185129e79d3c4f8738c0d6c2411950888969fee3bb32ecc8cdfbc84b0 WHIRLPOOL 2d10156012e8032abcf76f4de524fabc628420137df6a2bf307da93903a16293e7416ce11fa5c6f8104909d9ccb2fe6a195586257989cc13a5adf50e35c776d2
diff --git a/dev-python/sphinxcontrib-napoleon/sphinxcontrib-napoleon-0.6.1.ebuild b/dev-python/sphinxcontrib-napoleon/sphinxcontrib-napoleon-0.6.1.ebuild
new file mode 100644
index 000000000000..7816e405392f
--- /dev/null
+++ b/dev-python/sphinxcontrib-napoleon/sphinxcontrib-napoleon-0.6.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Allow a different format in dosctrings for better clarity"
+HOMEPAGE="https://sphinxcontrib-napoleon.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/sphinx-1.2[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.33[${PYTHON_USEDEP}]
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/pockets[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}