summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-20 12:14:06 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-20 14:18:24 +0200
commit5797743a4a5cfd8f1d5577106d9be23329608ade (patch)
tree4da5c96020b3bfed204fe7342297238e12e8e27d /dev-python/sphinxcontrib-openapi
parentdev-python/sphinxcontrib-newsfeed: EAPI 8, PEP517, rm namespace dep (diff)
downloadgentoo-5797743a4a5cfd8f1d5577106d9be23329608ade.tar.gz
gentoo-5797743a4a5cfd8f1d5577106d9be23329608ade.tar.bz2
gentoo-5797743a4a5cfd8f1d5577106d9be23329608ade.zip
dev-python/sphinxcontrib-openapi: Remove namespace dep
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-openapi')
-rw-r--r--dev-python/sphinxcontrib-openapi/sphinxcontrib-openapi-0.7.0-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-openapi/sphinxcontrib-openapi-0.7.0-r1.ebuild b/dev-python/sphinxcontrib-openapi/sphinxcontrib-openapi-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..7031a7727fa5
--- /dev/null
+++ b/dev-python/sphinxcontrib-openapi/sphinxcontrib-openapi-0.7.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenAPI (fka Swagger) spec renderer for Sphinx"
+HOMEPAGE="
+ https://pypi.org/project/sphinxcontrib-openapi/
+ https://github.com/sphinx-contrib/openapi/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-httpdomain[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/m2r[${PYTHON_USEDEP}]
+ dev-python/picobox[${PYTHON_USEDEP}]
+ dev-python/deepmerge[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ distutils_write_namespace sphinxcontrib
+ cd "${T}" || die
+ epytest "${S}"/tests
+}