summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-12-10 20:17:43 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-12-10 20:31:14 +0100
commite2f50f255000ca861f935356ef5e7e09543842c5 (patch)
tree9c0f4d3e1f7c9b70a6cc7bcafc5c4ab2c717cd27 /dev-python/spotipy
parentdev-lang/julia: bump to 1.8.3 (diff)
downloadgentoo-e2f50f255000ca861f935356ef5e7e09543842c5.tar.gz
gentoo-e2f50f255000ca861f935356ef5e7e09543842c5.tar.bz2
gentoo-e2f50f255000ca861f935356ef5e7e09543842c5.zip
dev-python/spotipy: bump to 2.22.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-python/spotipy')
-rw-r--r--dev-python/spotipy/Manifest1
-rw-r--r--dev-python/spotipy/spotipy-2.22.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/spotipy/Manifest b/dev-python/spotipy/Manifest
index 579958e8f0f1..8cb5888e5230 100644
--- a/dev-python/spotipy/Manifest
+++ b/dev-python/spotipy/Manifest
@@ -1 +1,2 @@
DIST spotipy-2.21.0.tar.gz 105500 BLAKE2B fa49c31da93efdac23fd5cbaa31b513f48e3a90c56dee8708bf695a20c1f6040c68a22a04d6589b3a890f503d54e7c0fb017f2911ae28abe54a9e7f5bff3b540 SHA512 8783261e43962b3e98cb9b680f908d38feecf784ff404352ba16d6bb3d2e4bf1d2308b60f1437c56402e1c2a993a5bba876103f968bb8bdd81be1aef1fe6d058
+DIST spotipy-2.22.0.gh.tar.gz 109714 BLAKE2B 178a05252bc875630cee97628d228d9bd7d929d54fcb7ee30e92b685996fc9074063eae25b0b71089c3b51fcb29611c101acf0f606dc14a508f37e46c5522041 SHA512 272f05b1cb92dbd9842dcac58a5ca322fae703eea58488b968812c12b6c26fb748aabbf5fde7100e9662191231fe12f5353b9ba12f02bd2e4982e0aff1c732f6
diff --git a/dev-python/spotipy/spotipy-2.22.0.ebuild b/dev-python/spotipy/spotipy-2.22.0.ebuild
new file mode 100644
index 000000000000..65f4113b7fbe
--- /dev/null
+++ b/dev-python/spotipy/spotipy-2.22.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A light weight Python library for the Spotify Web API"
+HOMEPAGE="https://spotipy.readthedocs.io"
+SRC_URI="https://github.com/plamere/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/redis-py[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Needs internet access
+ sed -i -e 's:test_spotify_client_credentials_get_access_token:_&:' \
+ tests/unit/test_oauth.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use examples && dodoc -r examples
+}