summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-05-14 19:24:43 +0200
committerMarek Szuba <marecki@gentoo.org>2021-05-14 19:31:39 +0200
commitbb3520a86b51deb4c0492082092163a505e7ee8d (patch)
treef48a8aaf414fc277ea859ca40e9ec135fe91fed4 /dev-python/stomp-py
parentsys-cluster/glusterfs: Stabilize 8.4 ppc, #790227 (diff)
downloadgentoo-bb3520a86b51deb4c0492082092163a505e7ee8d.tar.gz
gentoo-bb3520a86b51deb4c0492082092163a505e7ee8d.tar.bz2
gentoo-bb3520a86b51deb4c0492082092163a505e7ee8d.zip
dev-python/stomp-py: add 7.0.0
Nb. ready for python3_10 support, will add it as soon as dev-python/docopt has been updated for this as well. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/stomp-py')
-rw-r--r--dev-python/stomp-py/Manifest1
-rw-r--r--dev-python/stomp-py/stomp-py-7.0.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/stomp-py/Manifest b/dev-python/stomp-py/Manifest
index 36c72ae4158f..aff0d9f26843 100644
--- a/dev-python/stomp-py/Manifest
+++ b/dev-python/stomp-py/Manifest
@@ -1 +1,2 @@
DIST stomp.py-6.1.0.tar.gz 34690 BLAKE2B bf7ec2899be25bdc373e7d0d73281a6c4aa8b91a05e6ede263f0f9498b2ba3b9bd2c90b0fe472664c930dadf68ccaf09c74b69e7270259c3959396edff04e07b SHA512 73284b5dac8b9ef0d1251cc1059c4b1a545018a39498303d211fd165f0fb80439f2e01f82e18644cfd5d77a4badedcbced57d184ffc7c19f57945e5262f2394a
+DIST stomp.py-7.0.0.tar.gz 34772 BLAKE2B 838ee5ebf520bcf0c65d89b00e94c8cadb77204a4d387fa0261b8b8046d123d436fe587481c9a3db9d515b11fcdf246993c955834ff18b9161ff3355341caa3a SHA512 2cce1803125bb60c98ebf7c58c27130a13a2c42c0135e590752fae7a13a82edf3337c85f6ec2fb050e9ece0d3dc604a526610445a1a410fbe440ac8596608f34
diff --git a/dev-python/stomp-py/stomp-py-7.0.0.ebuild b/dev-python/stomp-py/stomp-py-7.0.0.ebuild
new file mode 100644
index 000000000000..3174c6674215
--- /dev/null
+++ b/dev-python/stomp-py/stomp-py-7.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS="pyproject.toml"
+
+inherit distutils-r1
+
+MY_PN="${PN//-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python client library for the STOMP messaging protocol"
+HOMEPAGE="https://pypi.org/project/stomp.py/ https://github.com/jasonrbriggs/stomp.py/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="<dev-python/docopt-0.7.0[${PYTHON_USEDEP}]"
+
+# stomp.py test suite requires quite a few appropriately configured
+# messaging servers (as of 7.0.0: RabbitMQ, ActiveMQ, ActiveMQ Artemis,
+# stompserver). Upstream relies on Docker to provide those servers, however
+# doing the same in src_test would require both granting the portage user
+# extra permissions and packaging the base image (trying to download it
+# on the fly would violate the network sandbox).
+# Side note: PyPI tarballs do not include tests.
+RESTRICT="test"
+
+S="${WORKDIR}"/${MY_P}