summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-21 20:20:28 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-21 21:11:45 +0200
commit332979f6741e47770b2dcb6d0b941c9642814a2d (patch)
tree78d9e92f9f9a56055647c5f7fc894e2b3a40cf68 /dev-python/testfixtures
parentdev-python/sentry-sdk: Bump to 1.4.0 (diff)
downloadgentoo-332979f6741e47770b2dcb6d0b941c9642814a2d.tar.gz
gentoo-332979f6741e47770b2dcb6d0b941c9642814a2d.tar.bz2
gentoo-332979f6741e47770b2dcb6d0b941c9642814a2d.zip
dev-python/testfixtures: Bump to 6.18.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/testfixtures')
-rw-r--r--dev-python/testfixtures/Manifest1
-rw-r--r--dev-python/testfixtures/testfixtures-6.18.2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/testfixtures/Manifest b/dev-python/testfixtures/Manifest
index 6e96254c9407..81c73c035016 100644
--- a/dev-python/testfixtures/Manifest
+++ b/dev-python/testfixtures/Manifest
@@ -1,2 +1,3 @@
DIST testfixtures-6.18.0.tar.gz 121584 BLAKE2B abf90012fe79d148c44d72a8aaa5277c95a33933c7b753eecdcaeb11279b4439ad9ea394270e440d9681c22789a17738d367b66adf3d04cf6e6289713c1ead59 SHA512 e6552e6b1837ae4ee4754ce3675bdbf2a68d8e46b892382bd8320290050f2c296348ef6310ce3ff46962bf1978c351fe2cdb853a73c9f800f68818f81d5caec9
DIST testfixtures-6.18.1.tar.gz 121731 BLAKE2B c31873d3ebbe47d5d3035d6aaaf674472efb32b061080df711ee558bf91d1b01d417ded4eaebf7436132fd7b9233437e735fa60dee47777d032fc1b610fd1de3 SHA512 088c6480eecc9862e91a0188ab45620be3d8f8898ebb284dc932155fffbd9f75ebbab9425fe4db8dee75ee8fcf82d8c27b950a3f9298e9f7ca420744c65edd91
+DIST testfixtures-6.18.2.tar.gz 122026 BLAKE2B 2b30c03ae71a300883ace52dc80e06c6b6610283687fa8df4ded1678991a47e8186de57060458a2fe98fc8eeb8fae8299081697a6471bdedcca2772405c91c6d SHA512 ee27d9944e8e8ec770199b115a50274f7167e9d3d3d866b0d0bbe7fec8a939b25a469ecac0158aaa486b129e078077c5822e7500ad473f98ba59862424413e15
diff --git a/dev-python/testfixtures/testfixtures-6.18.2.ebuild b/dev-python/testfixtures/testfixtures-6.18.2.ebuild
new file mode 100644
index 000000000000..c2e4ba7a58fd
--- /dev/null
+++ b/dev-python/testfixtures/testfixtures-6.18.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
+HOMEPAGE="https://pypi.org/project/testfixtures/ https://github.com/Simplistix/testfixtures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/sybil[${PYTHON_USEDEP}]
+ >=dev-python/twisted-18[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/Simplistix/testfixtures/commit/8fb2122eea0f1d0de1ccca7a3a0f5426bc6d4964
+ "${FILESDIR}/testfixtures-6.18.1-py3.10.patch"
+)
+
+python_prepare_all() {
+ # kill weird way of declaring build deps
+ sed -e '/build=/d' -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTHONPATH="."
+ local -x DJANGO_SETTINGS_MODULE=testfixtures.tests.test_django.settings
+ epytest -Wignore::DeprecationWarning
+}