summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-28 12:27:34 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-28 12:27:34 +0200
commit6493891b9a828e7e186665d54d76825fee4fe5fc (patch)
tree8817cb6c4f00ad3709cff1d8488c95b9cb3d0f78 /dev-python/testscenarios/testscenarios-0.5.0-r3.ebuild
parentdev-python/wstools: Revbump post dep change (diff)
downloadgentoo-6493891b9a828e7e186665d54d76825fee4fe5fc.tar.gz
gentoo-6493891b9a828e7e186665d54d76825fee4fe5fc.tar.bz2
gentoo-6493891b9a828e7e186665d54d76825fee4fe5fc.zip
dev-python/testscenarios: Add RDEP on dev-python/pbr
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/testscenarios/testscenarios-0.5.0-r3.ebuild')
-rw-r--r--dev-python/testscenarios/testscenarios-0.5.0-r3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/testscenarios/testscenarios-0.5.0-r3.ebuild b/dev-python/testscenarios/testscenarios-0.5.0-r3.ebuild
new file mode 100644
index 000000000000..c423d0812bf4
--- /dev/null
+++ b/dev-python/testscenarios/testscenarios-0.5.0-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A pyunit extension for dependency injection"
+HOMEPAGE="
+ https://launchpad.net/testscenarios/
+ https://github.com/testing-cabal/testscenarios/
+ https://pypi.org/project/testscenarios/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-python/testtools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
+"
+
+# using pytest for tests since unittest loader fails with py3.5+
+BDEPEND="
+ >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ testscenarios/tests/test_testcase.py
+)