summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2021-10-01 00:29:12 +0300
committerMichał Górny <mgorny@gentoo.org>2021-10-01 08:36:39 +0200
commit0d12174d17b6a8dc9050309730e48fca83b775b6 (patch)
treeba929ee15d5e2d6b584fcd2b32f9c819c4c50742 /dev-python/toposort
parentdev-python/requestsexceptions: enable py3.10 (diff)
downloadgentoo-0d12174d17b6a8dc9050309730e48fca83b775b6.tar.gz
gentoo-0d12174d17b6a8dc9050309730e48fca83b775b6.tar.bz2
gentoo-0d12174d17b6a8dc9050309730e48fca83b775b6.zip
dev-python/toposort: 1.7 version bump
The setup.py is removed by upstream in favor of pyproject.toml. Tests are now run explicitly. Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/22450 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/toposort')
-rw-r--r--dev-python/toposort/Manifest1
-rw-r--r--dev-python/toposort/toposort-1.7.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/toposort/Manifest b/dev-python/toposort/Manifest
index 6e30f532eec2..524a1795c6fb 100644
--- a/dev-python/toposort/Manifest
+++ b/dev-python/toposort/Manifest
@@ -1 +1,2 @@
DIST toposort-1.6.tar.gz 11690 BLAKE2B a9a57fd182a3324d43112c3f84a20039f032d99bf2c35c6678a6a08c23b123f18610f460529dd39c769b935d98270a25ded2f1a483e4e6f06d3ccc501b340cb8 SHA512 8dc30b5d5a6f476756520236bc93840243690779783ec8f0b5ef0f72c64d774177b25d10d2e024cda968f81352abbc4f89f3069760fc3a86bd5ee387e7951928
+DIST toposort-1.7.tar.gz 10671 BLAKE2B 89da22e803c334cec77d5ac8ad6a9ab8013f7516555c2822bd6d511edf28230c85c2eaeabad3dc4a24a58ae3ce3850d407ad957d0e28491574557140a286843a SHA512 a585d1c103b2162fa3f37f6b0ef60a8709f08d9543d7fab619af3718bf9f752a293e50061d370fd08872b2d8a8db504cb9d9c1cce5446885b46fe8e833813833
diff --git a/dev-python/toposort/toposort-1.7.ebuild b/dev-python/toposort/toposort-1.7.ebuild
new file mode 100644
index 000000000000..3002de7baf9a
--- /dev/null
+++ b/dev-python/toposort/toposort-1.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements a topological sort algorithm"
+HOMEPAGE="https://gitlab.com/ericvsmith/toposort"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+python_test() {
+ "${EPYTHON}" test/test_toposort.py || die
+}