summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-02 06:29:57 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-02 07:00:41 +0200
commitbf396b1869b459618cf18f7182cfa6f218e1b567 (patch)
tree593a3286d750d04ebcdfdde17ec2377428f60417 /dev-python/tornado
parentdev-python/lxml: Remove old (diff)
downloadgentoo-bf396b1869b459618cf18f7182cfa6f218e1b567.tar.gz
gentoo-bf396b1869b459618cf18f7182cfa6f218e1b567.tar.bz2
gentoo-bf396b1869b459618cf18f7182cfa6f218e1b567.zip
dev-python/tornado: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tornado')
-rw-r--r--dev-python/tornado/Manifest1
-rw-r--r--dev-python/tornado/files/tornado-6.4-pytest-8.2.patch66
-rw-r--r--dev-python/tornado/tornado-6.4-r1.ebuild63
3 files changed, 0 insertions, 130 deletions
diff --git a/dev-python/tornado/Manifest b/dev-python/tornado/Manifest
index 1aa1c1dcecb0..c766eb08e1da 100644
--- a/dev-python/tornado/Manifest
+++ b/dev-python/tornado/Manifest
@@ -1,2 +1 @@
DIST tornado-6.4.1.tar.gz 500623 BLAKE2B e359d9cbf5e7311e608753a2908e61ea121e4d108209866fda49e79ecca3dc8495c35583406dd7d6b2852c4f6a9df2e340b1f4b892489be976d70000ed51aa33 SHA512 294b4fff8a6d1b9592d355f7faf78f1a94a2aaea1b54414b7e81884b8d4069713a28f6105ae36f27be78abf4c47a1fceab3801bc92b5429374f7a534f104c437
-DIST tornado-6.4.tar.gz 498845 BLAKE2B ebcdcfa93490107addfe69f722e2d85058a92fc366b09a4794a4d6e0a93040ef9791095a5a94d21937d4e88dea09521644cf92d0f2c7e98238dc58e6b864a009 SHA512 c063509d4c385e410c63cccdc1e9c66aa2bb739473667ede56cb801b7379b910c8059dec831d609109f3076222b588b257afd960dffa422d7a872867dcdda7c7
diff --git a/dev-python/tornado/files/tornado-6.4-pytest-8.2.patch b/dev-python/tornado/files/tornado-6.4-pytest-8.2.patch
deleted file mode 100644
index 21a2ed04d24a..000000000000
--- a/dev-python/tornado/files/tornado-6.4-pytest-8.2.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-From c851aa8a949524b35f72c82b45a52353aa3c0558 Mon Sep 17 00:00:00 2001
-From: Ran Benita <ran@unusedvar.com>
-Date: Sun, 28 Apr 2024 14:17:54 +0300
-Subject: [PATCH] testing: allow to instantiate an empty AsyncTestCase
-
-`unittest.TestCase` has a feature where it allows instantiating
-`MyTestClass()` with the default method name `runTest` even if a
-`runTest` method doesn't actually exist. This is documented in
-`TestCase`'s docs under "Changed in version 3.2"[0].
-
-Since version 8.2, pytest relies on this, and started breaking on
-Tornado's `AsyncTestCase`[1].
-
-Change `AsyncTestCase` to allow empty instatiation, by matching the
-upstream code.
-
-[0] https://docs.python.org/3/library/unittest.html#unittest.TestCase
-[1] https://github.com/pytest-dev/pytest/issues/12263
----
- tornado/test/testing_test.py | 9 +++++++++
- tornado/testing.py | 12 +++++++++++-
- 2 files changed, 20 insertions(+), 1 deletion(-)
-
-diff --git a/tornado/test/testing_test.py b/tornado/test/testing_test.py
-index 0429feee83..8e2b8db428 100644
---- a/tornado/test/testing_test.py
-+++ b/tornado/test/testing_test.py
-@@ -61,6 +61,15 @@ def test_subsequent_wait_calls(self):
- self.io_loop.add_timeout(self.io_loop.time() + 0.2, self.stop)
- self.wait(timeout=0.4)
-
-+ def test_empty_instantation_is_allowed(self):
-+ """
-+ Test that empty instatiation of an AsyncTestCase is allowed.
-+
-+ unittest.TestCase docs guarantee this working, and pytest's unittest
-+ support relies on it.
-+ """
-+ AsyncTestCaseTest()
-+
-
- class LeakTest(AsyncTestCase):
- def tearDown(self):
-diff --git a/tornado/testing.py b/tornado/testing.py
-index bdbff87bc3..9455411a6d 100644
---- a/tornado/testing.py
-+++ b/tornado/testing.py
-@@ -177,7 +177,17 @@ def __init__(self, methodName: str = "runTest") -> None:
- # the test will silently be ignored because nothing will consume
- # the generator. Replace the test method with a wrapper that will
- # make sure it's not an undecorated generator.
-- setattr(self, methodName, _TestMethodWrapper(getattr(self, methodName)))
-+ try:
-+ test_method = getattr(self, methodName)
-+ except AttributeError:
-+ if methodName != "runTest":
-+ # We allow instantiation with no explicit method name
-+ # but not an *incorrect* or missing method name.
-+ raise ValueError(
-+ "no such test method in %s: %s" % (self.__class__, methodName)
-+ )
-+ else:
-+ setattr(self, methodName, _TestMethodWrapper(test_method))
-
- # Not used in this class itself, but used by @gen_test
- self._test_generator = None # type: Optional[Union[Generator, Coroutine]]
diff --git a/dev-python/tornado/tornado-6.4-r1.ebuild b/dev-python/tornado/tornado-6.4-r1.ebuild
deleted file mode 100644
index 3b5a869d5c2b..000000000000
--- a/dev-python/tornado/tornado-6.4-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python web framework and asynchronous networking library"
-HOMEPAGE="
- https://www.tornadoweb.org/
- https://github.com/tornadoweb/tornado/
- https://pypi.org/project/tornado/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- ${RDEPEND}
- $(python_gen_cond_dep '
- >=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
- ' 'python*')
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-6.3.2-test-timeout-increase.patch"
- "${FILESDIR}/${PN}-6.3.2-ignore-deprecationwarning.patch"
- # https://github.com/tornadoweb/tornado/pull/3374
- "${FILESDIR}/${P}-pytest-8.2.patch"
-)
-
-src_prepare() {
- # network-sandbox? ipv6?
- sed -i -e 's:test_localhost:_&:' \
- tornado/test/netutil_test.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x ASYNC_TEST_TIMEOUT=60
- # Avoid time-sensitive tests
- # https://github.com/tornadoweb/tornado/blob/10974e6ebee80a26a2a65bb9bd715cf858fafde5/tornado/test/util.py#L19
- local -x TRAVIS=1
- local -x NO_NETWORK=1
-
- cd "${T}" || die
- "${EPYTHON}" -m tornado.test.runtests --verbose ||
- die "tests failed under ${EPYTHON}"
-}