summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-28 08:21:20 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-28 08:21:20 +0100
commit809963d4d4a1aca388f160111583880a34effd53 (patch)
tree45cf407df9c9e04f34875064806d6fcf433a4bff /dev-python/translate-toolkit
parentdev-python/python-dbusmock: Bump to 0.34.2 (diff)
downloadgentoo-809963d4d4a1aca388f160111583880a34effd53.tar.gz
gentoo-809963d4d4a1aca388f160111583880a34effd53.tar.bz2
gentoo-809963d4d4a1aca388f160111583880a34effd53.zip
dev-python/translate-toolkit: Bump to 3.14.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/translate-toolkit')
-rw-r--r--dev-python/translate-toolkit/Manifest1
-rw-r--r--dev-python/translate-toolkit/translate-toolkit-3.14.5.ebuild119
2 files changed, 120 insertions, 0 deletions
diff --git a/dev-python/translate-toolkit/Manifest b/dev-python/translate-toolkit/Manifest
index 1aba09329931..7ed1bec041a4 100644
--- a/dev-python/translate-toolkit/Manifest
+++ b/dev-python/translate-toolkit/Manifest
@@ -2,3 +2,4 @@ DIST translate-3.14.1.gh.tar.gz 1174769 BLAKE2B 3be39dbf964307ebaaca651f06683ecf
DIST translate-3.14.2.gh.tar.gz 1175450 BLAKE2B db13e59036bd75a62847c68c4e2633a17152def48ccfd1d36531a0325b4b5d819711dab1cb3cfc23abc2e7201b348836434428ed155e6e593273ff8750038faa SHA512 7ae64bd93459b29e6a341ea8ded2993e02e277dbba48a0638eda28fff4dfcc9b490d0a669e277cb75c395f385e5a54feb0665919c27b1ab7c5cffd0add109d27
DIST translate-3.14.3.gh.tar.gz 1174793 BLAKE2B 9aad67c2bc390083dcacca53a41b99adeff679db4d576c054d8298da0e5114e5204128c94ee924cf4e5851378b3cec7b99d52b2dd12c5ece86562d45d05c205d SHA512 6f584ea46aceb4080eda2b05e3fbe51d76667d8afcac8da4e0b7644965aa833617db031329e315cbb18c6194e289a9054f127814372e97535bc40d765d65316e
DIST translate-3.14.4.gh.tar.gz 1174947 BLAKE2B 1a4f9b4b146145ef215ca0118c328c5c6153461b3f6899c665d1c69762bfe543ffffb7e590229b6d5ada5c5373b46484d4ebf6fbc4d9cac4b908174fde358d04 SHA512 4cb4b94f02858348c7e2e66cc3b0efa495084fbf03fb659ec701349f693c27647b11f2aefefca7b585b2c6e68a699149e85cedccbcf796e57edf825925e4f7d2
+DIST translate-3.14.5.gh.tar.gz 1175068 BLAKE2B d3627d8a69f98d01fceb3d8e233ff9d19238ff42aa5255e5f4b8372ecacb07f1cea02ff75c6e7e27eec684eeda207db83b91c6905edf7b82d93ca1a275db4564 SHA512 40467e48aeca0a51caf6baabce13a3daa3b643a5416a1dc8b8ce70198b7b6f13688f808c0e050ca2e2e6d977347dab59b454b6d9c537b4d615f623d5531bcc10
diff --git a/dev-python/translate-toolkit/translate-toolkit-3.14.5.ebuild b/dev-python/translate-toolkit/translate-toolkit-3.14.5.ebuild
new file mode 100644
index 000000000000..fc68f99127cf
--- /dev/null
+++ b/dev-python/translate-toolkit/translate-toolkit-3.14.5.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+MY_P=translate-${PV}
+DESCRIPTION="Toolkit to convert between many translation formats"
+HOMEPAGE="
+ https://github.com/translate/translate/
+ https://pypi.org/project/translate-toolkit/
+"
+SRC_URI="
+ https://github.com/translate/translate/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+html +ical +ini +subtitles +yaml"
+
+RDEPEND="
+ app-text/iso-codes
+ >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
+ dev-python/cheroot[${PYTHON_USEDEP}]
+ >=dev-python/levenshtein-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/mistletoe-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ >=dev-python/cwcwidth-0.1.9[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ html? ( dev-python/utidylib[${PYTHON_USEDEP}] )
+ ical? ( dev-python/vobject[${PYTHON_USEDEP}] )
+ ini? ( >=dev-python/iniparse-0.5[${PYTHON_USEDEP}] )
+ subtitles? ( media-video/gaupol[${PYTHON_USEDEP}] )
+ yaml? ( dev-python/pyyaml[${PYTHON_USEDEP}] )
+"
+# Technically, the test suite also has undeclared dependency
+# on dev-python/snapshottest but all the tests using it are broken
+# anyway, so we skip them.
+BDEPEND="
+ test? (
+ dev-python/phply[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # unfortunately, this bad quality package doesn't support XDG_DATA_DIRS
+ # correctly, so we need to reassemble all data files in a single directory
+ local -x XDG_DATA_HOME=${T}/share
+ cp -r translate/share "${T}/" || die
+ cp -r "${ESYSROOT}/usr/share"/gaupol "${XDG_DATA_HOME}"/ || die
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Fails with network-sandbox (and even with it off but w/ softer fail)
+ 'tests/xliff_conformance/test_xliff_conformance.py::test_open_office_to_xliff'
+ 'tests/xliff_conformance/test_xliff_conformance.py::test_po_to_xliff'
+ # all tests based on snapshottest are broken and I'm too tired
+ # to figure this out
+ tests/translate/tools/test_pocount.py::test_{cases,output}
+ tests/translate/tools/test_junitmsgfmt.py::test_output
+ )
+ local EPYTEST_IGNORE=(
+ # unpackaged fluent.*
+ tests/translate/storage/test_fluent.py
+ # changes directory and does not change it back, sigh
+ tests/odf_xliff/test_odf_xliff.py
+ )
+
+ if ! use ini; then
+ EPYTEST_IGNORE+=(
+ translate/convert/test_ini2po.py
+ translate/convert/test_po2ini.py
+ )
+ fi
+
+ if ! use subtitles; then
+ EPYTEST_IGNORE+=(
+ translate/storage/test_subtitles.py
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /usr
+ doins -r translate/share
+
+ if ! use html; then
+ rm "${ED}"/usr/bin/{html2po,po2html} || die
+ fi
+ if ! use ical; then
+ rm "${ED}"/usr/bin/{ical2po,po2ical} || die
+ fi
+ if ! use ini; then
+ rm "${ED}"/usr/bin/{ini2po,po2ini} || die
+ fi
+ if ! use subtitles; then
+ rm "${ED}"/usr/bin/{sub2po,po2sub} || die
+ fi
+}