summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-19 18:46:49 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-19 20:03:41 +0100
commit6ed79945dadf4ce5410039d0df50afbeb52b3815 (patch)
tree4435a9e4caa9e37b0bc4dc5cbc93cc919ae9bc0b /dev-python/trio-websocket
parentdev-python/pytest-asyncio: Bump to 0.21.0 (diff)
downloadgentoo-6ed79945dadf4ce5410039d0df50afbeb52b3815.tar.gz
gentoo-6ed79945dadf4ce5410039d0df50afbeb52b3815.tar.bz2
gentoo-6ed79945dadf4ce5410039d0df50afbeb52b3815.zip
dev-python/trio-websocket: Bump to 0.10.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trio-websocket')
-rw-r--r--dev-python/trio-websocket/Manifest1
-rw-r--r--dev-python/trio-websocket/trio-websocket-0.10.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/trio-websocket/Manifest b/dev-python/trio-websocket/Manifest
index 2347ad7960d0..6a2587b157a1 100644
--- a/dev-python/trio-websocket/Manifest
+++ b/dev-python/trio-websocket/Manifest
@@ -1,2 +1,3 @@
DIST trio-websocket-0.10.0.gh.tar.gz 43808 BLAKE2B fd89ab74c3844a14940ce07a0abc07a0392607b492fa4b6e1d81ba3aa2c37338706975cb800332751c9ea70e934c4169fdcd29dd047019096726164a2130daa9 SHA512 04d775a7c1a232b470a7f415b57debce4bd1c3732934a94d65e3c9f3bb45c5ffea7464557100e2e9f68a2aa6a7812bd686220de046f399a0d0242309d2d9be59
DIST trio-websocket-0.10.1.gh.tar.gz 44657 BLAKE2B c7e895c5beccf40baa8603f1e3c62396e4d8c716d9a51b6977c0854f65b4c40a1edb40812f80d55f0530c2e59f10f27f2b62f72a6fb91c693ae0d67aeff3161c SHA512 bd26d72c5de70d8176b62c950e6c2bf6cf47ed5a55bb63f88e675a9d353076be45f45387da8fa9af71b8915d93914844f2a7a662351e4776c4714734512bdd7c
+DIST trio-websocket-0.10.2.gh.tar.gz 45025 BLAKE2B cc80f7b8e06bb88bef69c6326dd899a27523ea70e0ea10c8b02a26498102638c569ffe21e2b4e355f9c635d60ae8ae34664d311bf5fe286456e43e0f9c2ba481 SHA512 ad8d4facb153b59597ca7dac14dabe60ac8ca4331aa72df8120e01ec726e1f392a8167d070f72534eb735b5dbf4afe46e385c0e3a2dd250afa2280c6a5a0c863
diff --git a/dev-python/trio-websocket/trio-websocket-0.10.2.ebuild b/dev-python/trio-websocket/trio-websocket-0.10.2.ebuild
new file mode 100644
index 000000000000..b95a0f2797fc
--- /dev/null
+++ b/dev-python/trio-websocket/trio-websocket-0.10.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="WebSocket client and server implementation for Python Trio"
+HOMEPAGE="
+ https://github.com/HyperionGray/trio-websocket/
+ https://pypi.org/project/trio-websocket/
+"
+SRC_URI="
+ https://github.com/HyperionGray/trio-websocket/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/exceptiongroup[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.11[${PYTHON_USEDEP}]
+ >=dev-python/wsproto-0.14[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pytest-trio-0.5.0[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p trio
+}