summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-17 06:15:40 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-17 06:15:40 +0200
commite965c3452b1e981f9df10fa67a667f1e42912328 (patch)
treed34f1502ae133248d6dc637f07e345ddbc8919ba /dev-python/typeguard
parentdev-python/simplejson: Remove old (diff)
downloadgentoo-e965c3452b1e981f9df10fa67a667f1e42912328.tar.gz
gentoo-e965c3452b1e981f9df10fa67a667f1e42912328.tar.bz2
gentoo-e965c3452b1e981f9df10fa67a667f1e42912328.zip
dev-python/typeguard: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/typeguard')
-rw-r--r--dev-python/typeguard/Manifest3
-rw-r--r--dev-python/typeguard/files/typeguard-2.13.3-test.patch44
-rw-r--r--dev-python/typeguard/typeguard-2.13.3-r1.ebuild49
-rw-r--r--dev-python/typeguard/typeguard-3.0.0.ebuild45
-rw-r--r--dev-python/typeguard/typeguard-3.0.1.ebuild45
5 files changed, 0 insertions, 186 deletions
diff --git a/dev-python/typeguard/Manifest b/dev-python/typeguard/Manifest
index 2b01cfd43441..ade5ffe6b10b 100644
--- a/dev-python/typeguard/Manifest
+++ b/dev-python/typeguard/Manifest
@@ -1,4 +1 @@
-DIST typeguard-2.13.3.gh.tar.gz 37436 BLAKE2B a3cb616692119c64a9dc0d0bae25cc661b7974a0b6cf6632fa403f7c5430873570b1aaa310bc03843deee6f77a831c303ea9d9091db596eb565fce43980bbb13 SHA512 26c31ee9670650d1969320187a924d29d986894a38f1026af58f705b132b64be3b6e2ac34729f966f5d302d486334b5a5d9e65fb206245b82b0ff0852020b609
-DIST typeguard-3.0.0.tar.gz 55330 BLAKE2B b0b764414c70e109e5bdddd1bfac06af5b0db8d8913e2777b4bec94598ae70f5ed323686f54d902c541c606e7ae32129b3a29099e59cfe5ff2ecad4e6991409e SHA512 367ffea6636817bf9ce492de575b38b1f15aec323d415476bdea271f01ee60073274fd955bdad0e554eb306fb4e516b80a29e5db10015cf47856279235e36c24
-DIST typeguard-3.0.1.tar.gz 56196 BLAKE2B f53bfc7571063bc74588356cbff513311b0100079f42c3d8188ae430ffc1cf3ff2b7599a6ed0973ae02bb9d5d1818abc1c63a24d453592e630a4ac794ef4a5e4 SHA512 07d0276033730a6fc345aeabcbeb68f3b9740cb8336ed8ad731f75925d3bd9007ce050514bd98d39c1b85a4615ddf503420686ccd8ff6513c2610e40b8f89504
DIST typeguard-3.0.2.tar.gz 58171 BLAKE2B d11b9592c191f131a48c8545a1ffbc4dcf4fc32f12dd0ba0bbab84c11ae1d6ba4cf6126fdc5d5b9b2ba81f07a3047f8328c7a8c29c1779238a04b12d4fe8b01c SHA512 a8f87494d4962cfa451ab266fb2958867acb677ec07acad0e8ccead16b9f3d59facffbe133de4e7808147caefb2b41c184b19bc82a812d041e90c3c1c1c0667a
diff --git a/dev-python/typeguard/files/typeguard-2.13.3-test.patch b/dev-python/typeguard/files/typeguard-2.13.3-test.patch
deleted file mode 100644
index 3c01c018ea86..000000000000
--- a/dev-python/typeguard/files/typeguard-2.13.3-test.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff --git a/src/typeguard/__init__.py b/src/typeguard/__init__.py
-index 5684d63..27fa30b 100644
---- a/src/typeguard/__init__.py
-+++ b/src/typeguard/__init__.py
-@@ -61,22 +61,25 @@ except ImportError:
- from typing import _ForwardRef as ForwardRef
- evaluate_forwardref = ForwardRef._eval_type
-
--if sys.version_info >= (3, 10):
-- from typing import is_typeddict
--else:
-- _typed_dict_meta_types = ()
-- if sys.version_info >= (3, 8):
-- from typing import _TypedDictMeta
-- _typed_dict_meta_types += (_TypedDictMeta,)
-+try:
-+ from typing_extensions import is_typeddict
-+except ImportError:
-+ if sys.version_info >= (3, 10):
-+ from typing import is_typeddict
-+ else:
-+ _typed_dict_meta_types = ()
-+ if sys.version_info >= (3, 8):
-+ from typing import _TypedDictMeta
-+ _typed_dict_meta_types += (_TypedDictMeta,)
-
-- try:
-- from typing_extensions import _TypedDictMeta
-- _typed_dict_meta_types += (_TypedDictMeta,)
-- except ImportError:
-- pass
-+ try:
-+ from typing_extensions import _TypedDictMeta
-+ _typed_dict_meta_types += (_TypedDictMeta,)
-+ except ImportError:
-+ pass
-
-- def is_typeddict(tp) -> bool:
-- return isinstance(tp, _typed_dict_meta_types)
-+ def is_typeddict(tp) -> bool:
-+ return isinstance(tp, _typed_dict_meta_types)
-
-
- if TYPE_CHECKING:
diff --git a/dev-python/typeguard/typeguard-2.13.3-r1.ebuild b/dev-python/typeguard/typeguard-2.13.3-r1.ebuild
deleted file mode 100644
index d40683e5eb2b..000000000000
--- a/dev-python/typeguard/typeguard-2.13.3-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Run-time type checker for Python"
-HOMEPAGE="
- https://pypi.org/project/typeguard/
- https://github.com/agronholm/typeguard/
-"
-SRC_URI="
- https://github.com/agronholm/typeguard/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-PATCHES=(
- # backport from https://github.com/agronholm/typeguard/pull/243
- "${FILESDIR}"/${P}-test.patch
-)
-
-python_test() {
- local EPYTEST_IGNORE=(
- # mypy changes results from version to version
- tests/mypy
- )
-
- local -x PYTHONDONTWRITEBYTECODE=
- epytest
-}
diff --git a/dev-python/typeguard/typeguard-3.0.0.ebuild b/dev-python/typeguard/typeguard-3.0.0.ebuild
deleted file mode 100644
index 45c5399f1af2..000000000000
--- a/dev-python/typeguard/typeguard-3.0.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Run-time type checker for Python"
-HOMEPAGE="
- https://pypi.org/project/typeguard/
- https://github.com/agronholm/typeguard/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- $(python_gen_cond_dep '
- >=dev-python/importlib_metadata-3.6[${PYTHON_USEDEP}]
- ' 3.{8..9})
- $(python_gen_cond_dep '
- >=dev-python/typing-extensions-4.4.0[${PYTHON_USEDEP}]
- ' 3.{8..10})
-"
-BDEPEND="
- >=dev-python/setuptools-scm-6.4[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_IGNORE=(
- # mypy changes results from version to version
- tests/mypy
- )
-
- local -x PYTHONDONTWRITEBYTECODE=
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- # the XFAIL test pass due to some package being installed
- epytest -o xfail_strict=False
-}
diff --git a/dev-python/typeguard/typeguard-3.0.1.ebuild b/dev-python/typeguard/typeguard-3.0.1.ebuild
deleted file mode 100644
index 45c5399f1af2..000000000000
--- a/dev-python/typeguard/typeguard-3.0.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Run-time type checker for Python"
-HOMEPAGE="
- https://pypi.org/project/typeguard/
- https://github.com/agronholm/typeguard/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- $(python_gen_cond_dep '
- >=dev-python/importlib_metadata-3.6[${PYTHON_USEDEP}]
- ' 3.{8..9})
- $(python_gen_cond_dep '
- >=dev-python/typing-extensions-4.4.0[${PYTHON_USEDEP}]
- ' 3.{8..10})
-"
-BDEPEND="
- >=dev-python/setuptools-scm-6.4[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_IGNORE=(
- # mypy changes results from version to version
- tests/mypy
- )
-
- local -x PYTHONDONTWRITEBYTECODE=
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- # the XFAIL test pass due to some package being installed
- epytest -o xfail_strict=False
-}