summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-16 21:23:02 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-16 21:41:24 +0300
commit1e735cd335c1564717f73b66a0ddc1a8232216ed (patch)
tree87870e190d92416fcee2b4754176146e55912e5b /dev-python/ukkonen
parentx11-drivers/nvidia-drivers: add 510.73.05 (diff)
downloadgentoo-1e735cd335c1564717f73b66a0ddc1a8232216ed.tar.gz
gentoo-1e735cd335c1564717f73b66a0ddc1a8232216ed.tar.bz2
gentoo-1e735cd335c1564717f73b66a0ddc1a8232216ed.zip
dev-python/ukkonen: PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/ukkonen')
-rw-r--r--dev-python/ukkonen/ukkonen-1.0.1-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/ukkonen/ukkonen-1.0.1-r1.ebuild b/dev-python/ukkonen/ukkonen-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..61b6de821b97
--- /dev/null
+++ b/dev-python/ukkonen/ukkonen-1.0.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Implementation of bounded Levenshtein distance (Ukkonen)"
+HOMEPAGE="
+ https://pypi.org/project/ukkonen/
+ https://github.com/asottile/ukkonen/"
+SRC_URI="
+ https://github.com/asottile/ukkonen/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')"
+BDEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-musl-include.patch
+)
+
+distutils_enable_tests pytest