summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-01-13 17:46:03 +0100
committerJeroen Roovers <jer@gentoo.org>2017-01-13 17:46:03 +0100
commitca71811e81edfa5ad360abf1c79fbd926a7fd978 (patch)
treed97bb876747cd7849072ca412cbfafae04fb5fd5 /dev-python/unidecode/unidecode-0.04.20.ebuild
parentx11-terms/sakura: Version bump. (diff)
downloadgentoo-ca71811e81edfa5ad360abf1c79fbd926a7fd978.tar.gz
gentoo-ca71811e81edfa5ad360abf1c79fbd926a7fd978.tar.bz2
gentoo-ca71811e81edfa5ad360abf1c79fbd926a7fd978.zip
dev-python/unidecode: Version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/unidecode/unidecode-0.04.20.ebuild')
-rw-r--r--dev-python/unidecode/unidecode-0.04.20.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/unidecode/unidecode-0.04.20.ebuild b/dev-python/unidecode/unidecode-0.04.20.ebuild
new file mode 100644
index 000000000000..fa2a6fbeefaa
--- /dev/null
+++ b/dev-python/unidecode/unidecode-0.04.20.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+
+MY_PN=Unidecode
+MY_P=${MY_PN}-${PV}
+
+inherit distutils-r1
+
+DESCRIPTION="Module providing ASCII transliterations of Unicode text"
+HOMEPAGE="https://pypi.python.org/pypi/Unidecode"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}