summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-22 16:43:12 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-22 17:37:38 +0200
commit9c7df500600c2d809458a048e62196e431b42ecf (patch)
tree807ebf2b67b9cad4b01c9a3b19891c240131b17d /dev-python/utidylib
parentdev-python/ujson: Remove old (diff)
downloadgentoo-9c7df500600c2d809458a048e62196e431b42ecf.tar.gz
gentoo-9c7df500600c2d809458a048e62196e431b42ecf.tar.bz2
gentoo-9c7df500600c2d809458a048e62196e431b42ecf.zip
dev-python/utidylib: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/utidylib')
-rw-r--r--dev-python/utidylib/Manifest2
-rw-r--r--dev-python/utidylib/utidylib-0.6-r2.ebuild49
-rw-r--r--dev-python/utidylib/utidylib-0.7-r2.ebuild27
-rw-r--r--dev-python/utidylib/utidylib-0.7-r3.ebuild28
4 files changed, 0 insertions, 106 deletions
diff --git a/dev-python/utidylib/Manifest b/dev-python/utidylib/Manifest
index cab22b729b09..d6764c451d75 100644
--- a/dev-python/utidylib/Manifest
+++ b/dev-python/utidylib/Manifest
@@ -1,3 +1 @@
-DIST uTidylib-0.6.tar.gz 15771 BLAKE2B 9d4fe57d985ea6e52680bd528862d3236137221227a23fe05b886d01d240e21d7159dbf7d6da3af8020009ca45c60c2297e374bb7aa05cb6b5a8eaf444710c58 SHA512 a85506ef8824f66ee326ad651020dc3b4e00190e20dcd3814984fa27ff319f492fe5bac781b7c43c8694cbfc63409e3abda18981969c9be2c3cd023fe7a4f2f8
-DIST utidylib-0.7.gh.tar.gz 15203 BLAKE2B c32f23ab3a94191423655f9b6a99bd85aca7072fcfea7507c5d4efb19c4ee22114afe136c6299e8322e15195c4f938094e49483b1a40d05522f2d232dd9a6acd SHA512 69b22671223cc9e1888a1be19b418e883baa79401bcf3856fa48cca441ae7fa414047c296f8fc9ff35aa7407901fa64cd8ddfcc56657a98e8e188073dfc72172
DIST utidylib-0.8.gh.tar.gz 15285 BLAKE2B 85f0ec1a969f31cb952e326a5bce5f51d9a5bacdf33d7e703cc3a464621df86f568921a9dd17755be67d49c02631782cdabb4112ee7cf8e321079656bb362122 SHA512 cb9c868337e1bbfa80ac36ca1b3f85c4e35f62acb67dbd321167d568da17d9e562fdca6b777d88c08e03107401fbadc7cdebf243654bcde9825259117e36392f
diff --git a/dev-python/utidylib/utidylib-0.6-r2.ebuild b/dev-python/utidylib/utidylib-0.6-r2.ebuild
deleted file mode 100644
index 688f03a99a99..000000000000
--- a/dev-python/utidylib/utidylib-0.6-r2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8,9} )
-
-MY_P="uTidylib-${PV}"
-inherit distutils-r1
-
-DESCRIPTION="TidyLib Python wrapper"
-HOMEPAGE="https://cihar.com/software/utidylib/ https://pypi.org/project/uTidylib/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm64 ppc ppc64 x86"
-IUSE="doc test"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-DEPEND="
- dev-python/six[${PYTHON_USEDEP}]
-"
-RDEPEND="
- >=app-text/htmltidy-5.0.0
-"
-
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/utidylib/utidylib-0.7-r2.ebuild b/dev-python/utidylib/utidylib-0.7-r2.ebuild
deleted file mode 100644
index acc23f255f9a..000000000000
--- a/dev-python/utidylib/utidylib-0.7-r2.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-MY_P="uTidylib-${PV}"
-inherit distutils-r1
-
-DESCRIPTION="TidyLib Python wrapper"
-HOMEPAGE="https://cihar.com/software/utidylib/ https://pypi.org/project/uTidylib/"
-SRC_URI="https://github.com/nijel/utidylib/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm64 ppc ~ppc64 ~riscv x86"
-
-RDEPEND=">=app-text/htmltidy-5.0.0"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs
-
-EPYTEST_DESELECT=(
- # https://github.com/nijel/utidylib/issues/9
- tidy/test_tidy.py::TidyTestCase::test_missing_load
-)
diff --git a/dev-python/utidylib/utidylib-0.7-r3.ebuild b/dev-python/utidylib/utidylib-0.7-r3.ebuild
deleted file mode 100644
index 1e2d9febb1f4..000000000000
--- a/dev-python/utidylib/utidylib-0.7-r3.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-MY_P="uTidylib-${PV}"
-inherit distutils-r1
-
-DESCRIPTION="TidyLib Python wrapper"
-HOMEPAGE="https://cihar.com/software/utidylib/ https://pypi.org/project/uTidylib/"
-SRC_URI="https://github.com/nijel/utidylib/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~riscv ~x86"
-
-RDEPEND=">=app-text/htmltidy-5.0.0"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs
-
-EPYTEST_DESELECT=(
- # https://github.com/nijel/utidylib/issues/9
- tidy/test_tidy.py::TidyTestCase::test_missing_load
-)