summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-26 07:00:37 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-26 07:00:37 +0200
commitaf8e5057945c7d8762f8eddde57487d0b8eafd08 (patch)
tree08a4578088810affe4468de1228fe8fed4f5d0f4 /dev-python/uv
parentapp-admin/awscli: Bump to 1.35.15 (diff)
downloadgentoo-af8e5057945c7d8762f8eddde57487d0b8eafd08.tar.gz
gentoo-af8e5057945c7d8762f8eddde57487d0b8eafd08.tar.bz2
gentoo-af8e5057945c7d8762f8eddde57487d0b8eafd08.zip
dev-python/uv: Bump to 0.4.27
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/uv')
-rw-r--r--dev-python/uv/Manifest1
-rw-r--r--dev-python/uv/uv-0.4.27.ebuild144
2 files changed, 145 insertions, 0 deletions
diff --git a/dev-python/uv/Manifest b/dev-python/uv/Manifest
index 73f4755ead8a..5468675818d6 100644
--- a/dev-python/uv/Manifest
+++ b/dev-python/uv/Manifest
@@ -11,3 +11,4 @@ DIST uv-0.4.25-crates.tar.xz 45691104 BLAKE2B ff0c2f51dbc00a7ed636e652c9641ec497
DIST uv-0.4.25.gh.tar.gz 2766139 BLAKE2B d3dbb50f34f6ce5df6885b6ce3fc04a943c472e2550f013c3fcc1d6b5d65b2418adf321d584f133f71ef0cdeb3b33acf03dc8fe211664e28e910937f6a50ffdf SHA512 c278d60ee09031e11c53e5862025a4e546c67a00ffa01da744658ca02a53507cd8f9fe9f0bce2cb7c29466ececd7f45e73f3db2c9b58d3451dd02a918e9213c2
DIST uv-0.4.26-crates.tar.xz 45699316 BLAKE2B 87409df6d4ff9462225000d8c3e4cb4f29c460f94043b28accc227e8dc5cc78aaf362a43e4f7df09b20e1354afdd414d5d260ed2742162e9c307d1e7641ead16 SHA512 321c61ef404cb10753fef2bc7aa2be89fdd1b3e2d77065400874044af1987f7d8eea85af259bc3d678bb56f97c185ac1c6d0f6f769b25fc732a1153c3c9b0d39
DIST uv-0.4.26.gh.tar.gz 2772725 BLAKE2B 46ea8245fdb0a38ad924e4d65d1c247f11c2419de1466b99f62ee486b0c3fc7a7dedf4a8d5168fc9b4bf062741b7865dd07d29cd1ab0e92772810982c10029d5 SHA512 e4ed845687641b1054703ec5419a34947409504353fbfc1f56aab3dbafa72c1705170f71b569fb8c92d549dc2d7ce26cd1fa4010e23d0360310743821d37b653
+DIST uv-0.4.27.gh.tar.gz 2796691 BLAKE2B 8c4c04f912fc4c9ec6eceebd9853bbdf148f1d12f68836d8e4a92743ca1be405d7f5d8a5e3f09dd70360f078d0e93db6e878a9ed4cdcd6f876990b9a2ad41eb2 SHA512 6ba5f1b5fb0d427b75ec528d8ef40d020de11ddb81efc4638ed4b9d0244ccd1d630577c0f4d9fae6e3b303fcdeee51623406540de3b6974d4a22282884157e33
diff --git a/dev-python/uv/uv-0.4.27.ebuild b/dev-python/uv/uv-0.4.27.ebuild
new file mode 100644
index 000000000000..20c05fb19bde
--- /dev/null
+++ b/dev-python/uv/uv-0.4.27.ebuild
@@ -0,0 +1,144 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES="
+"
+
+declare -A GIT_CRATES=(
+ [async_zip]='https://github.com/charliermarsh/rs-async-zip;011b24604fa7bc223daaad7712c0694bac8f0a87;rs-async-zip-%commit%'
+ [pubgrub]='https://github.com/astral-sh/pubgrub;7243f4faf8e54837aa8a401a18406e7173de4ad5;pubgrub-%commit%'
+ [reqwest-middleware]='https://github.com/TrueLayer/reqwest-middleware;d95ec5a99fcc9a4339e1850d40378bbfe55ab121;reqwest-middleware-%commit%/reqwest-middleware'
+ [reqwest-retry]='https://github.com/TrueLayer/reqwest-middleware;d95ec5a99fcc9a4339e1850d40378bbfe55ab121;reqwest-middleware-%commit%/reqwest-retry'
+ [tl]='https://github.com/charliermarsh/tl;6e25b2ee2513d75385101a8ff9f591ef51f314ec;tl-%commit%'
+)
+
+inherit cargo check-reqs
+
+CRATE_PV=0.4.26
+DESCRIPTION="A Python package installer and resolver, written in Rust"
+HOMEPAGE="
+ https://github.com/astral-sh/uv/
+ https://pypi.org/project/uv/
+"
+# pypi sdist misses scripts/, needed for tests
+SRC_URI="
+ https://github.com/astral-sh/uv/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ ${CARGO_CRATE_URIS}
+"
+if [[ ${PKGBUMPING} != ${PVR} ]]; then
+ SRC_URI+="
+ https://dev.gentoo.org/~mgorny/dist/uv-${CRATE_PV}-crates.tar.xz
+ "
+fi
+
+# most of the code
+LICENSE="|| ( Apache-2.0 MIT )"
+# crates/pep508-rs is || ( Apache-2.0 BSD-2 ) which is covered below
+# Dependent crate licenses
+LICENSE+="
+ 0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD-2 BSD ISC MIT
+ MPL-2.0 Unicode-DFS-2016
+"
+# ring crate
+LICENSE+=" openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="test"
+PROPERTIES="test_network"
+
+DEPEND="
+ app-arch/bzip2:=
+ app-arch/xz-utils:=
+ app-arch/zstd:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=virtual/rust-1.80
+ test? (
+ dev-lang/python:3.8
+ dev-lang/python:3.9
+ dev-lang/python:3.10
+ dev-lang/python:3.11
+ dev-lang/python:3.12
+ )
+"
+
+QA_FLAGS_IGNORED="usr/bin/.*"
+
+check_space() {
+ local CHECKREQS_DISK_BUILD=3G
+ use debug && CHECKREQS_DISK_BUILD=9G
+ check-reqs_pkg_setup
+}
+
+pkg_pretend() {
+ check_space
+}
+
+pkg_setup() {
+ check_space
+}
+
+src_prepare() {
+ default
+
+ # remove patch.* that breaks GIT_CRATES
+ local reqmw=${GIT_CRATES[reqwest-middleware]}
+ reqmw=${reqmw#*;}
+ reqmw=${reqmw%;*}
+ sed -i -e "/^\[patch/,\$s@^\(reqwest-middleware = \).*@\1 { path = \"${WORKDIR}/reqwest-middleware-${reqmw}/reqwest-middleware\" }@" Cargo.toml || die
+
+ # enable system libraries where supported
+ export ZSTD_SYS_USE_PKG_CONFIG=1
+ # TODO: unbundle libz-ng-sys, tikv-jemalloc-sys?
+
+ # remove unbundled sources, just in case
+ find "${ECARGO_VENDOR}"/{bzip2,lzma,zstd}-sys-*/ -name '*.c' -delete || die
+
+ # bzip2-sys requires a pkg-config file
+ # https://github.com/alexcrichton/bzip2-rs/issues/104
+ mkdir "${T}/pkg-config" || die
+ export PKG_CONFIG_PATH=${T}/pkg-config${PKG_CONFIG_PATH+:${PKG_CONFIG_PATH}}
+ cat >> "${T}/pkg-config/bzip2.pc" <<-EOF || die
+ Name: bzip2
+ Version: 9999
+ Description:
+ Libs: -lbz2
+ EOF
+}
+
+src_configure() {
+ local myfeatures=(
+ git
+ pypi
+ python
+ )
+
+ cargo_src_configure --no-default-features
+}
+
+src_compile() {
+ cd crates/uv || die
+ cargo_src_compile
+}
+
+src_test() {
+ # work around https://github.com/astral-sh/uv/issues/4376
+ local -x PATH=${BROOT}/usr/lib/python-exec/python3.12:${PATH}
+ local -x COLUMNS=100
+ local -x PYTHONDONTWRITEBYTECODE=
+
+ cd crates/uv || die
+ cargo_src_test --no-fail-fast
+}
+
+src_install() {
+ cd crates/uv || die
+ cargo_src_install
+}