summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2016-04-01 22:20:13 +0600
committerAndrey Grozin <grozin@gentoo.org>2016-04-01 22:20:13 +0600
commit464fb45e98cb788c007ffea53b046d12b04b1ec4 (patch)
treee793b64b6c93ed7af9bc4390039fe541ce741474 /dev-python/wcwidth
parentRevert "x11-misc/qt5ct: Qt5 Configuration Tool" (diff)
downloadgentoo-464fb45e98cb788c007ffea53b046d12b04b1ec4.tar.gz
gentoo-464fb45e98cb788c007ffea53b046d12b04b1ec4.tar.bz2
gentoo-464fb45e98cb788c007ffea53b046d12b04b1ec4.zip
dev-python/wcwidth: added python3_5
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/wcwidth')
-rw-r--r--dev-python/wcwidth/wcwidth-0.1.6-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/wcwidth/wcwidth-0.1.6-r1.ebuild b/dev-python/wcwidth/wcwidth-0.1.6-r1.ebuild
new file mode 100644
index 000000000000..bbc123d1e92a
--- /dev/null
+++ b/dev-python/wcwidth/wcwidth-0.1.6-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Measures number of Terminal column cells of wide-character codes"
+HOMEPAGE="https://pypi.python.org/pypi/wcwidth/ https://github.com/jquast/wcwidth"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ py.test -v -rs --strict wcwidth/tests || die
+}