summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-19 18:08:19 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-19 18:25:55 +0100
commit66513f0a4f37c6868a6192bb09b637dfbc6dec4c (patch)
tree33e3f1da89ef4843041e46d4c3e7af5a3e007154 /dev-python/xmlschema
parentwww-client/firefox: drop 118.0.2, 119.0, 119.0.1, 120.0 (diff)
downloadgentoo-66513f0a4f37c6868a6192bb09b637dfbc6dec4c.tar.gz
gentoo-66513f0a4f37c6868a6192bb09b637dfbc6dec4c.tar.bz2
gentoo-66513f0a4f37c6868a6192bb09b637dfbc6dec4c.zip
dev-python/xmlschema: Bump to 2.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xmlschema')
-rw-r--r--dev-python/xmlschema/Manifest1
-rw-r--r--dev-python/xmlschema/xmlschema-2.5.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/xmlschema/Manifest b/dev-python/xmlschema/Manifest
index b8d9b05d06e6..7ff8288aa944 100644
--- a/dev-python/xmlschema/Manifest
+++ b/dev-python/xmlschema/Manifest
@@ -1 +1,2 @@
DIST xmlschema-2.5.0.tar.gz 539358 BLAKE2B 3d70b01f325ed1b4b61b1baaf1d7d29fd9748984f229d78bc645fef331d2cfb6f6d6e52200295ced0e03513e105ebfb8f30937c51e0883ee5d67866346cddb02 SHA512 d859be35d057d8bb1cea85c0f90525ae26f78f09ba2a111414f429eb2afd8633cb59ec0d701bba5bd1d086efb7ae51c2c470882cbfb932caa51c8b8d1ecbfbcb
+DIST xmlschema-2.5.1.tar.gz 539267 BLAKE2B 6eae451f1331fd506e8f70b8d00505f6773b6aa82599bad5a94662704d045411a60e86e96f946b20d8c9d6c79b1bd61bfcac65f00ac0273eab89d27f75bdb73a SHA512 b968323581140a768d44cbd7fec08638f556204a4c75dc608b1f78868a68dc3fe3103a2c03dfa79601301043807478bc08ded63923ec26c4425ebdf48fdf0c7e
diff --git a/dev-python/xmlschema/xmlschema-2.5.1.ebuild b/dev-python/xmlschema/xmlschema-2.5.1.ebuild
new file mode 100644
index 000000000000..0d98d02ad092
--- /dev/null
+++ b/dev-python/xmlschema/xmlschema-2.5.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="An XML Schema validator and decoder"
+HOMEPAGE="
+ https://github.com/sissaschool/xmlschema/
+ https://pypi.org/project/xmlschema/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ <dev-python/elementpath-5[${PYTHON_USEDEP}]
+ >=dev-python/elementpath-4.1.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" tests/test_all.py -v || die "Tests fail with ${EPYTHON}"
+}