summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2022-09-26 21:07:44 -0700
committerZac Medico <zmedico@gentoo.org>2022-09-26 21:09:08 -0700
commit8d6f63f25b221f5f497d48841ebdc796cee161b5 (patch)
tree0b67e5f084eeb98368fd75adf5a242875909c71e /dev-python/yamlpath
parentsys-firmware/edk2-ovmf: drop 202105-r1 (diff)
downloadgentoo-8d6f63f25b221f5f497d48841ebdc796cee161b5.tar.gz
gentoo-8d6f63f25b221f5f497d48841ebdc796cee161b5.tar.bz2
gentoo-8d6f63f25b221f5f497d48841ebdc796cee161b5.zip
dev-python/yamlpath: add 3.6.6
Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/yamlpath')
-rw-r--r--dev-python/yamlpath/Manifest1
-rw-r--r--dev-python/yamlpath/yamlpath-3.6.6.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/yamlpath/Manifest b/dev-python/yamlpath/Manifest
index a1ff257227e5..7698c79652a6 100644
--- a/dev-python/yamlpath/Manifest
+++ b/dev-python/yamlpath/Manifest
@@ -1,2 +1,3 @@
DIST yamlpath-3.6.4.gh.tar.gz 216016 BLAKE2B fc6537b7c80ecfb9f69c646970e43935374bb105df007c123cf837eb1de6827ac2cc443294b69500c966ea6bc5d7f56498aec13340238c7660118f17cc6685e5 SHA512 eb1ac0d5861818f4f4b57b07f9fa7f758846982abbb3ac4ec58a1adaca8ec36deba1e21ce3e13916e74a946512f4d66e341a9d45392ef7133d0293e5fd6f66c9
DIST yamlpath-3.6.5.gh.tar.gz 216508 BLAKE2B df1d849840356eb75d9e19a5b53ec94ce140d7474be2fde19ab7f438229d347f247ee3c0f25cef4948f71d95d6935aebc0f8e58bc869083849820f9d641d7f22 SHA512 1d80514516eb573b0c644af7eaab7211714e271cc4334db5d965e2da58f06d26b3cdcb8c1412d03151a196e1b48aeb0c0d5038364a09907bb2af1efa71dd71f3
+DIST yamlpath-3.6.6.gh.tar.gz 222605 BLAKE2B b8e4345e68bb03b9aa48f31813ead149a1e547bab36deacfc255b6d8bb62148ed11bed6495e3e8db14b48859717ee87386e6d740c8b33dbf16bf4923bc19bbcf SHA512 3699cd2af82c77b29de60d0912dd5fc858a7b10ac960a8944dd0566073a7bdf5bccc6378d5aa6e52498482e51aa00cb2cae53f2a089308617d1358d744b5efcc
diff --git a/dev-python/yamlpath/yamlpath-3.6.6.ebuild b/dev-python/yamlpath/yamlpath-3.6.6.ebuild
new file mode 100644
index 000000000000..1517368d7013
--- /dev/null
+++ b/dev-python/yamlpath/yamlpath-3.6.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Command-line processors for YAML/JSON/Compatible data"
+HOMEPAGE="https://github.com/wwkimball/yamlpath https://github.com/wwkimball/yamlpath/wiki"
+SRC_URI="
+ https://github.com/wwkimball/yamlpath/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-ruby/hiera-eyaml
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare_all() {
+ sed -e '/ruamel\.yaml/d' \
+ -e '/pytest-cov/d' \
+ -e "/find_packages/s/()/(exclude=\['tests'\])/" \
+ -i setup.py || die
+
+ touch yamlpath/patches/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # install and optimize yamlpath/patches/aliasstyle.py
+ local sitedir=$(python_get_sitedir)
+ [[ -d ${D}${sitedir} ]] || die "${D}${sitedir}: No such directory"
+ insinto "${sitedir}/yamlpath"
+ doins -r "${S}/yamlpath/patches"
+ python_optimize "${D}${sitedir}"
+}