summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-04 13:31:34 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-04 14:44:55 +0100
commit0beede837191f4c62fa0ce6f58c63cdb1ee917fb (patch)
tree39569967f28ae99b114908ebfd003ebabbcd6ec5 /dev-python
parentnet-analyzer/zabbix: drop fping suid check in postinst (diff)
downloadgentoo-0beede837191f4c62fa0ce6f58c63cdb1ee917fb.tar.gz
gentoo-0beede837191f4c62fa0ce6f58c63cdb1ee917fb.tar.bz2
gentoo-0beede837191f4c62fa0ce6f58c63cdb1ee917fb.zip
dev-python/pytest-asyncio: Bump to 0.23.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-asyncio/Manifest1
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.23.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index fd1f4b44282a..32782fd97935 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -2,3 +2,4 @@ DIST pytest-asyncio-0.21.1.tar.gz 30492 BLAKE2B 6a17f9ba89b8181b5fb734af6d0c0904
DIST pytest-asyncio-0.22.0.tar.gz 37081 BLAKE2B 62941bdf10ee8a5195e900e71c7eba1810edd9721457656fc0b62dca3264f4ce0cba9221f80fd8a5249ee30e662cf068fcc8e491ba6b297e0370fcb04b7fe068 SHA512 7880b03c44997b0cb05b1c9633bf3e94e7eefc0396dc88512baf0e8f700508fa76eb9cbf2ce6d837be9ae0f1efb75343cdc32c7b2983e294ffa30e94893a3a2c
DIST pytest-asyncio-0.23.0.tar.gz 43658 BLAKE2B 893b446018ce460825555b1f42c36b27a0c2330d08e7588a4f59e8b6390390040b49cee02f27369f3135e95402eab7e3573bbae381e5ce81f23e578b1f21fa9d SHA512 903ec009617385c2e95fcb03e1fe23b5d372f5aaa334c5156b0fe19aab7c3d0272e7e5869a89a6b1c4b3282deba5e37b0832a54518455e48af0ef2a51f4b9ce6
DIST pytest-asyncio-0.23.1.tar.gz 43991 BLAKE2B b0e9b169b8b2b1eec12cc016b514dceeba1ea59df6e1b1ae83858412460db0d53ac128b05c15b6b75200a17fa2bcbf922f8f33ccba1f642319214f843a578393 SHA512 f4ddc4d097ede4ea340e93a44df0cc6ec7f0443623d7f994d09a902a81d1d12a61a3ad2f11da7fb276cff748a26a37984e6390b0264f79f4f536d64085bbd9ab
+DIST pytest-asyncio-0.23.2.tar.gz 44174 BLAKE2B 36dbd0022416eef05c781b9f74fd143bb52fe0583461ca7e52fd4981d552bbefdddd8e3a3399bc229a8ae68b150e199237ae0ce3a375075ab8f7f507bfa59316 SHA512 aa5b5fe8b633b187303dd2958d2ea01561604044507da107e46115d9bf4c1ac3c78826b4b6a6cbf474a6ee4ce0cd1bede87a2c8fe0d35397ddf6a4069437dd84
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.23.2.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.23.2.ebuild
new file mode 100644
index 000000000000..c35e42670f46
--- /dev/null
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.23.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Library for testing asyncio code with pytest"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-asyncio/
+ https://pypi.org/project/pytest-asyncio/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on precise warning counts
+ tests/hypothesis/test_base.py::test_can_use_explicit_event_loop_fixture
+ tests/modes/test_legacy_mode.py
+ tests/modes/test_strict_mode.py::test_strict_mode_ignores_unmarked_fixture
+ tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_fixture_leaves_loop_unclosed
+ tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_test_leaves_loop_unclosed
+ tests/test_pytest_min_version_warning.py
+ tests/trio/test_fixtures.py::test_strict_mode_ignores_trio_fixtures
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_asyncio.plugin,_hypothesis_pytestplugin
+ epytest
+}