summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-12 08:41:54 +0000
committerSam James <sam@gentoo.org>2021-12-12 08:48:49 +0000
commit24da026ada8e90c3800ee7ac9ddb38313d395dc4 (patch)
tree564d568157a1c0ef0dae61346c43ee739a479a2c /dev-python
parentdev-lang/tk: Bump to 8.6.12 (diff)
downloadgentoo-24da026ada8e90c3800ee7ac9ddb38313d395dc4.tar.gz
gentoo-24da026ada8e90c3800ee7ac9ddb38313d395dc4.tar.bz2
gentoo-24da026ada8e90c3800ee7ac9ddb38313d395dc4.zip
dev-python/ukkonen: fix build on musl
Closes: https://bugs.gentoo.org/828871 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ukkonen/files/ukkonen-1.0.1-musl-include.patch15
-rw-r--r--dev-python/ukkonen/ukkonen-1.0.1.ebuild6
2 files changed, 20 insertions, 1 deletions
diff --git a/dev-python/ukkonen/files/ukkonen-1.0.1-musl-include.patch b/dev-python/ukkonen/files/ukkonen-1.0.1-musl-include.patch
new file mode 100644
index 000000000000..0be1be4adefd
--- /dev/null
+++ b/dev-python/ukkonen/files/ukkonen-1.0.1-musl-include.patch
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/828871
+https://github.com/asottile/ukkonen/commit/1b2aa2833b08e00279ff77612e82dad152eb3c14.patch
+
+From: Joonas Niilola <juippis@gentoo.org>
+Date: Sat, 11 Dec 2021 10:39:16 +0200
+Subject: [PATCH] _ukkonen.cpp: add #include <cstdint>
+
+--- a/_ukkonen.cpp
++++ b/_ukkonen.cpp
+@@ -1,4 +1,5 @@
+ #include <algorithm>
++#include <cstdint>
+ #include <vector>
+
+ template <typename T> int64_t edit_distance_k_impl(
diff --git a/dev-python/ukkonen/ukkonen-1.0.1.ebuild b/dev-python/ukkonen/ukkonen-1.0.1.ebuild
index a4cc21241192..bd7bbdbacc80 100644
--- a/dev-python/ukkonen/ukkonen-1.0.1.ebuild
+++ b/dev-python/ukkonen/ukkonen-1.0.1.ebuild
@@ -22,6 +22,10 @@ RDEPEND="
$(python_gen_cond_dep '
dev-python/cffi[${PYTHON_USEDEP}]
' 'python*')"
-BDEPEND=${RDEPEND}
+BDEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-musl-include.patch
+)
distutils_enable_tests pytest