summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-22 12:34:42 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-22 14:04:45 +0200
commit7769213f0015534642605a46f47595d2708c57c1 (patch)
tree47486a467494184a2640dc82982cef0bdee22211 /dev-python
parentnet-proxy/lyrebird: Stabilize 0.1.0 x86, #912753 (diff)
downloadgentoo-7769213f0015534642605a46f47595d2708c57c1.tar.gz
gentoo-7769213f0015534642605a46f47595d2708c57c1.tar.bz2
gentoo-7769213f0015534642605a46f47595d2708c57c1.zip
dev-python/pydantic: Bump to 2.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pydantic/Manifest1
-rw-r--r--dev-python/pydantic/pydantic-2.2.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/pydantic/Manifest b/dev-python/pydantic/Manifest
index 3a305548db5b..1d8a14b6ff66 100644
--- a/dev-python/pydantic/Manifest
+++ b/dev-python/pydantic/Manifest
@@ -1,3 +1,4 @@
DIST pydantic-1.10.12.gh.tar.gz 766366 BLAKE2B b00885b86ef331f3f8531d1514f4e3e1ef10d009b35453c6d5a6295ecfe2d2b842f66c7ea2a79ca1d235d54fa38b42432e14804163f944c4455f05c06869815a SHA512 413d433decfa3bb7173d6f4e6e06f746cfbf95f6d27c6a17098216ba81d64d7f8bb956cda195d0676559f96278f3800c77be53ecf46496ac009f130120642cc2
DIST pydantic-2.1.1.tar.gz 611057 BLAKE2B b414fa698fdc8aee12427d38d0c410ffdd9a39e271858f939587c4a58cd3f579f9d5406b44c1c27350040a036af3badf58b4e10657b52b2d8a720e37720dcda3 SHA512 02703bb889d517f14a977835e553356ddd4d25abf4c8e30df157d68d8006a7ac9ed95feeda73548560b5705ca0d2305af8c49d683d5f0178e48643bef03761e2
DIST pydantic-2.2.0.tar.gz 620963 BLAKE2B 64b32daf0d6161a70364bdf21e4f868547253106ded166212faf7ae6dc4861ca21078c0f261af1e86b4d300de790f59bb641b76f0c046172a1240fce0135be86 SHA512 b9558cc9ba7da65507e13beb553e616a653169600c2898d783fcb761286674add7afccb39b90400875c0fe1b1a6fdde6e028fae39770fe3be767a9cdb94df5af
+DIST pydantic-2.2.1.tar.gz 621074 BLAKE2B f0d987f51b18b13cf384433108eefa58c2fe9da98f514a351edab7dbdafaf8941f6eb946af7d81f88363d827a15df8e2fae5e901be69f5c4d19e0adf237ef773 SHA512 b79e49cdd81130aba44c6e122515cf8db121569be16b20bd1cc74c9983c25a2d4b8e532d49fe364782c40a28a3758f8e7f4c99e6e88a6e5470ee8ef214d51eb5
diff --git a/dev-python/pydantic/pydantic-2.2.1.ebuild b/dev-python/pydantic/pydantic-2.2.1.ebuild
new file mode 100644
index 000000000000..a22a3c722319
--- /dev/null
+++ b/dev-python/pydantic/pydantic-2.2.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Data parsing and validation using Python type hints"
+HOMEPAGE="
+ https://github.com/pydantic/pydantic/
+ https://pypi.org/project/pydantic/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/annotated-types-0.4.0[${PYTHON_USEDEP}]
+ ~dev-python/pydantic-core-2.6.1[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.6.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/hatch-fancy-pypi-readme-22.5.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/dirty-equals[${PYTHON_USEDEP}]
+ >=dev-python/email-validator-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/Faker-18.13.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/benchmark/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ local EPYTEST_IGNORE=(
+ # require pytest-examples
+ tests/test_docs.py
+ # benchmarks
+ tests/benchmarks
+ )
+ case ${EPYTHON} in
+ python3.12)
+ EPYTEST_DESELECT+=(
+ tests/test_abc.py::test_model_subclassing_abstract_base_classes_without_implementation_raises_exception
+ tests/test_computed_fields.py::test_abstractmethod_missing
+ tests/test_edge_cases.py::test_abstractmethod_missing_for_all_decorators
+ tests/test_generics.py::test_partial_specification_name
+ tests/test_model_signature.py::test_annotated_field
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_mock
+}