summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-23 05:47:56 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-23 06:09:44 +0200
commit7eb8e17578b48052259ebe38172589cb5072142a (patch)
tree796a18952b395c81e9a93d46ffd1341c69b380db /dev-python
parentapp-admin/awscli: Bump to 1.29.32 (diff)
downloadgentoo-7eb8e17578b48052259ebe38172589cb5072142a.tar.gz
gentoo-7eb8e17578b48052259ebe38172589cb5072142a.tar.bz2
gentoo-7eb8e17578b48052259ebe38172589cb5072142a.zip
dev-python/pybtex-docutils: Bump to 1.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pybtex-docutils/Manifest1
-rw-r--r--dev-python/pybtex-docutils/pybtex-docutils-1.0.3.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pybtex-docutils/Manifest b/dev-python/pybtex-docutils/Manifest
index 7c08680f3589..f6db167ed1a3 100644
--- a/dev-python/pybtex-docutils/Manifest
+++ b/dev-python/pybtex-docutils/Manifest
@@ -1 +1,2 @@
DIST pybtex-docutils-1.0.2.tar.gz 18450 BLAKE2B 84521d36994e3ca5bfdcebd308e6aaeb17f7202d024799612d34dbf58b1b1e58d42b898a4c792815a472b0a7008e28558fd722f39462cd3b1ee24b921f746a4d SHA512 1190fcbdfb89b858a1164dd2c99a5da7afb76a23f5b314963babd894e7578d75e80f2552319c6621e9c7738018fd1b8f4a3772057ed65466f2d9fc3e15c57e2b
+DIST pybtex-docutils-1.0.3.tar.gz 18348 BLAKE2B 49a614d0e718a968ce1a8fb0e0cb105f86a97b51e29be34b3a542c4de1135ef4abf3406f4d5b5063ea21ab39fa94a89ad5ea8c1fff2354618fbdf0241cd52b65 SHA512 36c0f06a89333ed4153c70399a1eb2a220fb453da7af16fac7a28234dc576d5cb4f1809747c7070f711d611f0e967784aff77ffed63431517fd846aeb0e500df
diff --git a/dev-python/pybtex-docutils/pybtex-docutils-1.0.3.ebuild b/dev-python/pybtex-docutils/pybtex-docutils-1.0.3.ebuild
new file mode 100644
index 000000000000..6f0a293610dc
--- /dev/null
+++ b/dev-python/pybtex-docutils/pybtex-docutils-1.0.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A docutils backend for pybtex"
+HOMEPAGE="
+ https://github.com/mcmtroffaes/pybtex-docutils/
+ https://pypi.org/project/pybtex-docutils/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/docutils-0.14[${PYTHON_USEDEP}]
+ >=dev-python/pybtex-0.16[${PYTHON_USEDEP}]
+
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc