summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-11 07:15:59 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-11 07:17:43 +0200
commit954c391411cab9d481d837d9acb4afd70d38a6aa (patch)
tree2455d7f97e5c3e3ec8c2f41b404a1e59edf52cb9 /dev-python
parentdev-python/aiostream: Bump to 0.6.1 (diff)
downloadgentoo-954c391411cab9d481d837d9acb4afd70d38a6aa.tar.gz
gentoo-954c391411cab9d481d837d9acb4afd70d38a6aa.tar.bz2
gentoo-954c391411cab9d481d837d9acb4afd70d38a6aa.zip
dev-python/tifffile: Bump to 2024.5.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/tifffile/Manifest1
-rw-r--r--dev-python/tifffile/tifffile-2024.5.10.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
index 6a3c8de8c372..0ce3456a2995 100644
--- a/dev-python/tifffile/Manifest
+++ b/dev-python/tifffile/Manifest
@@ -1,2 +1,3 @@
DIST tifffile-2024.4.24.gh.tar.gz 346320 BLAKE2B 55f755044a6ee3826beaa8c9d39e5351474d73a64bd2af7d7e31dc20ac156c762b93a5d4986cd3dab8a70ed3b1674fe47e7ed07834a8833dcfa15fe6f179ccb5 SHA512 7ca3b32596210878e24c48475df8b95b193906669f0c561ba0567b6159fe951dd0d89ab83b094ba859da526e6c456d21e4b53bcc6038824556a0391d48a601f5
+DIST tifffile-2024.5.10.gh.tar.gz 347939 BLAKE2B d2295e04ba9dd90ae9b61e8d62263faf8d14293d4f29c3324b0f5e0078cd8e710a2193c0f0f000c7b4c14d54b76dc2e838b188620537e82e77e8b7b63a5cb575 SHA512 e460caf9c3424923f50babc7c8b8030cc7cc7ff9b1d915568cfdecd753e006659dda860948c9568eafc67aac621948675f7ab7e5468c7c0e72ba626fbde039e4
DIST tifffile-2024.5.3.gh.tar.gz 347188 BLAKE2B 965b216c69f3257870298303ed165e6c5a9a581c079ec349156e40e8d812dd21cf2b8f7b2d3036ae4f2357296e6c6035ac52d8b7e799dd57b0c63287415c1a70 SHA512 46d90a78c0cf8111fd7c9a22ead8f4b8e1715a57cb0e7be0112027e44495d8d239ebe87433e94865b0925e47eb43af13b720318e906c63c0848c52e4f17f22d7
diff --git a/dev-python/tifffile/tifffile-2024.5.10.ebuild b/dev-python/tifffile/tifffile-2024.5.10.ebuild
new file mode 100644
index 000000000000..190a5b9ccada
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2024.5.10.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.cgohlke.com/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local -x SKIP_LARGE=1
+ local -x SKIP_HTTP=1
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}