summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-20 06:40:40 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-20 06:40:40 +0200
commitc5562adb1a6b6c63bf0c8672ad70644707b8686e (patch)
treef0f7fe065f358ace62f29bce6379edab9964ee6b /dev-python
parentdev-python/Faker: Bump to 29.0.0 (diff)
downloadgentoo-c5562adb1a6b6c63bf0c8672ad70644707b8686e.tar.gz
gentoo-c5562adb1a6b6c63bf0c8672ad70644707b8686e.tar.bz2
gentoo-c5562adb1a6b6c63bf0c8672ad70644707b8686e.zip
dev-python/nbxmpp: Bump to 5.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/nbxmpp/Manifest1
-rw-r--r--dev-python/nbxmpp/nbxmpp-5.0.4.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/nbxmpp/Manifest b/dev-python/nbxmpp/Manifest
index b592a22663ff..6c354b0d1552 100644
--- a/dev-python/nbxmpp/Manifest
+++ b/dev-python/nbxmpp/Manifest
@@ -1,2 +1,3 @@
DIST python-nbxmpp-4.5.4.tar.bz2 138170 BLAKE2B 00a4919032dd29828dc735695afe9c0814a8fe2ec765a534257768896d9f27bc3a395275d546ad717bdd16c97161e8f0a8acaf43cdb7bd9404e40bc72f2c3da5 SHA512 fcaedae519d8cd2d52cc65721ab1e743569ba1cf7c29f2db41ed5671ba0f2c5b47f1f6d9521e1614e89e21512a4575c6788316cdb86936f0c4886d54c3831bb3
DIST python-nbxmpp-5.0.3.tar.bz2 142891 BLAKE2B 5a73660357e0ce5056f34290e6b1148a4e36af82c88ace89a562b0a5675422d364047d16604856c5ac81a87a3f262651b65c97cff79fd95dad508a4a2977c15f SHA512 ae433fe943dcc996bf10cb5c0cda70bd15b825fa40d7cb49a16e86476074dffa3b0f6a2286a03ef9bde11f572be447fc615ca157895de0dcba598ab74262b48a
+DIST python-nbxmpp-5.0.4.tar.bz2 143198 BLAKE2B ac27204205ded7e0d20237ee7f70e5f84f8f4ada54951e209a30c59390fe166ef296875e45dd74216a04ba78d35968667d4f126967d97c57dd1533ce4d9edd0e SHA512 a6672b4046c2de596ca92129782574528d14ee75a7982bb32db398628e3901c8e780b8a33fac2710d13367a0990ba21ef148c255fa77dee219c6bbd0c453d935
diff --git a/dev-python/nbxmpp/nbxmpp-5.0.4.ebuild b/dev-python/nbxmpp/nbxmpp-5.0.4.ebuild
new file mode 100644
index 000000000000..0299ed984918
--- /dev/null
+++ b/dev-python/nbxmpp/nbxmpp-5.0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=python-nbxmpp-${PV}
+DESCRIPTION="Python library to use Jabber/XMPP networks in a non-blocking way"
+HOMEPAGE="
+ https://dev.gajim.org/gajim/python-nbxmpp/
+ https://pypi.org/project/nbxmpp/
+"
+SRC_URI="
+ https://dev.gajim.org/gajim/python-nbxmpp/-/archive/${PV}/${MY_P}.tar.bz2
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+
+RDEPEND="
+ dev-libs/gobject-introspection
+ net-libs/libsoup:3.0[introspection]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/precis-i18n-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.42[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest