summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-09 06:08:18 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-09 06:58:50 +0100
commitfa267542e50f0ebdc85cb5e1b72412eb5930772f (patch)
treef1e8a96bac23578fc72433a9eb75d27629ffd20d /dev-python
parentdev-python/sphinx-gallery: Bump to 0.12.0 (diff)
downloadgentoo-fa267542e50f0ebdc85cb5e1b72412eb5930772f.tar.gz
gentoo-fa267542e50f0ebdc85cb5e1b72412eb5930772f.tar.bz2
gentoo-fa267542e50f0ebdc85cb5e1b72412eb5930772f.zip
dev-python/trimesh: Bump to 3.20.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/trimesh/Manifest1
-rw-r--r--dev-python/trimesh/trimesh-3.20.2.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index 5eaaf9450adc..4b6de5d33bbd 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -2,3 +2,4 @@ DIST trimesh-3.18.1.gh.tar.gz 12657109 BLAKE2B 8e5370193e7d47f1dc2d7d43c356df1a5
DIST trimesh-3.19.4.gh.tar.gz 12673418 BLAKE2B c54e0e1a946b858371d5de2f028bbc64a353a06859f428d6e221058a46e853bb7f245d7348b1cc7fbbdb930ba9600e24a39c2884a9acfa00b9d31d6576b87959 SHA512 b490e6d021a41c0a094c5e3596033a189d08310c04a2ce70c9b72d492e1cad1b5c9f110487c66d0a37eed97754e979c7b449d10a6a6abdbd81241099c248d5cf
DIST trimesh-3.20.0.gh.tar.gz 12678960 BLAKE2B f99ff3d7fd1a84e1ce9b6d1d67b38216aa8b3e3250096f2ac7c4585fffe0a4e565c093bf30bd98bf46daa910c80266edd12dbd43c5a2aef8a7d66c75b08972cb SHA512 82eb81d8b43880d1205c31ddcc085735cfc0bf64eb4918fd539fe5b476c107f484ff1b969d6f8bdb0ac2486d201ba1ff4316b84311afc38853ffbe8f13d0fb9b
DIST trimesh-3.20.1.gh.tar.gz 12681880 BLAKE2B 138c10b4e57971e155770f4d398e364a6c4e827d564bb6be608e93c4ba17bd3a06c313e73308069635143d974c945a9231785102bc14c024382675f66675b9eb SHA512 09c048e3a22abecafb8f163ab8273565f244ba232cc988673bce09efbc8696ba92aa53ec57bff41fe90605b032ef147889331de38580948ee04333dbfc608635
+DIST trimesh-3.20.2.gh.tar.gz 12683352 BLAKE2B 3ed73e426fd72723d19b668aae790f44ad46b310b6ddbbedf1e87aa56880037fa09b43921131ce2a5bff02022e6630222c63fb205a4345e81959e14b0013c3fa SHA512 fb6ca184b9d62e7820f1b92c8ce67a02eed6355c49dbb209b328e149ab6e600c306a10bcbae3bceaaec0244874eebc8bdf06709310f8458e9f72ee9ad213ad65
diff --git a/dev-python/trimesh/trimesh-3.20.2.ebuild b/dev-python/trimesh/trimesh-3.20.2.ebuild
new file mode 100644
index 000000000000..842ffb868e16
--- /dev/null
+++ b/dev-python/trimesh/trimesh-3.20.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimsh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ sci-libs/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/mapbox_earcut[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -n "$(makeopts_jobs)"
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox_earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" sci-libs/scikit-image
+}